[Buri][Call setings][Flight mode]Can still set the voice mail when open the flight mode

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
5 years ago
3 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

94.98 KB, application/octet-stream
Details
119.62 KB, image/x-png
Details
(Reporter)

Description

5 years ago
Mozilla build ID:20130902041201
 Created an attachment (id=515806)
 pic1
 
 DEFECT DESCRIPTION:
  Can still set the voice mail when open the flight mode
  REPRODUCING PROCEDURES:
  1.Enter the call Settings,open the flight mode;
  2.The voice mail not gray and can setting the voice mail-KO.
  EXPECTED BEHAVIOUR:
  Unable to set the voice mail when flight mode opened.
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Medium
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 804187 [details]
PR522851.log
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 804188 [details]
pic1
Component: Gaia::SMS → Gaia::Settings
You enable flight mode from the quick settings bar, do you? If you enable flight mode from the main panel from the setting app you shouldn't be able to open the call settings panel. Anyway setting the VM # doesn't have telephony implication since the VM # is stored in the setting database and that's it. IMHO this behavior works for me.

Comment 6

5 years ago
If you open the call settings panel firstly and then enable the flight mode. You can still set voicemail. While in other OS, call settings will exit automatically when you enable the flight mode.

Comment 7

3 years ago
ni UX for right behaviour
Flags: needinfo?(thsieh)

Updated

2 years ago
Blocks: 1258652
Flags: needinfo?(thsieh)

Comment 8

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.