Closed Bug 915971 Opened 7 years ago Closed 7 years ago

Rename "ReturnValue" unions to "Owning" unions

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Whiteboard: [need review]
Comment on attachment 804191 [details] [diff] [review]
Rename FooReturnValue unions to OwningFoo, because we use them for more than just return values.

Review of attachment 804191 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/bindings/Codegen.py
@@ +813,1 @@
>  

What do you think of naming this ownsMembers instead?  I think it's a little clearer, but I don't care much either way.
Attachment #804191 - Flags: review?(dzbarsky) → review+
Which "this"?  I think you have Splinter quoting fail...
Flags: needinfo?(dzbarsky)
(In reply to Boris Zbarsky [:bz] from comment #3)
> Which "this"?  I think you have Splinter quoting fail...

Hmm, weird. FWIW you can click on review to see my comments in the splinter view.  I was talking about 
owningUnionStructs[name] = CGUnionStruct(t, providers[0],
                                         isOwning=True)
Flags: needinfo?(dzbarsky)
Ah.  Yes, makes sense.  Will do.
https://hg.mozilla.org/integration/mozilla-inbound/rev/99a789a320c7
Flags: in-testsuite-
Whiteboard: [need review]
Target Milestone: --- → mozilla27
https://hg.mozilla.org/mozilla-central/rev/99a789a320c7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.