[Marionette] Marionette import_js is trying to do strange behavior

RESOLVED DUPLICATE of bug 909129

Status

RESOLVED DUPLICATE of bug 909129
5 years ago
5 years ago

People

(Reporter: wachen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
when you import javascript file, marionette server just keeps pushing javascript into one single js file. marionette server should establish a certain mechanism for server to check if the js is appended or not.

Suggested solution:
1) eastablish different js files and check if the newly imported file hash duplicated
2) some ways to check if the functions in a file is imported and try to remove or substitute them
(Reporter)

Comment 1

5 years ago
For gaia_ui_test
Also, setUp() in gaia_test.py needed to be modified, too.
There are GaiaApp, GaiaDataLayer, and LockScreen scripts to be imported everytime a test case started to run. They should be moved to __init__ function so that it will only be imported once in gaia_test
the file is "marionettescriptchrome"  and located in /data/local/tmp/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 909129
You need to log in before you can comment on or make changes to this bug.