Closed Bug 916023 Opened 9 years ago Closed 9 years ago

Add Gaia functional UI tests to official repository

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

defect
Not set
critical

Tracking

(b2g-v1.1hd fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.1hd --- fixed

People

(Reporter: davehunt, Unassigned)

References

Details

(Whiteboard: [gaia-ui-test])

Attachments

(2 files)

We're going to move the remaining functional UI tests to the Gaia repository.
Attachment #804700 - Flags: review?(jgriffin)
Attachment #804700 - Flags: feedback?(jlal)
Blocks: 916305
Whiteboard: [gaia-ui-test]
Comment on attachment 804700 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12225

Looks good.  Will this be the canonical location of these tests now?  I think the answer is 'yes', which will require us to update the mozharness script for running these tests.
Attachment #804700 - Flags: review?(jgriffin) → review+
(In reply to Jonathan Griffin (:jgriffin) from comment #2)
> Will this be the canonical location of these tests now?  I
> think the answer is 'yes', which will require us to update the mozharness
> script for running these tests.

Yes, thanks for raising bug 916375 for this.
I seem to have lost commit access to Gaia. While I get this reinstated, could someone please land this for me? Thanks.
Flags: needinfo?(jlal)
Flags: needinfo?(jgriffin)
Comment on attachment 804880 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12227

Here's the patch for v1-train.
Attachment #804880 - Flags: review?(jgriffin)
We recently had to close the tree due to some major regressions in gecko/mc [travis was broken]. I sent an email out to dev-gaia but I am not sure who is on that list... I just sent out an email to webqa about signing up so we have one central place to talk about the major changes in gaia. The tree is now open and you should have access once again.
Flags: needinfo?(jlal)
(In reply to James Lal [:lightsofapollo] from comment #7)
> The tree is now open and you should have access once again.

Thanks! Landed on master as:
https://github.com/mozilla-b2g/gaia/commit/7ac57fc63a7ce282c1b2216ca3f93740acf67a8a
Flags: needinfo?(jgriffin)
Attachment #804700 - Flags: feedback?(jlal)
Blocks: 916696
Comment on attachment 804880 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12227

Thanks Dave.
Attachment #804880 - Flags: review?(jgriffin) → review+
Landed on v1-train as:
https://github.com/mozilla-b2g/gaia/commit/862b5761825e010e3cc5968c096377e1ea54bbf2
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
v1.1.0hd: 862b5761825e010e3cc5968c096377e1ea54bbf2
You need to log in before you can comment on or make changes to this bug.