If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][Data usage]The data usage page become white when answer the call.

RESOLVED FIXED

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: alive)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Firefox os  v1.1
  Mozilla build ID:20130902041201
 
 Created an attachment (id=517250)
 logcat
 
 DEFECT DESCRIPTION:
  The data usage page become white when answer the call.
 
  REPRODUCING PROCEDURES:
  prepare 2 device:A、B(B is the test device)
  1、long tap the device B idle screen
  2、make a MT call(A call B) and B answer the call,then device A hang up
  3、then open the data usage from the notification bar
  4、click the home button,the the screen become white-->KO
 
  EXPECTED BEHAVIOUR:
  the data usage can be used normally
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:High
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 804371 [details]
logcat
(Reporter)

Updated

4 years ago
blocking-b2g: --- → leo?
(Reporter)

Comment 3

4 years ago
Hello mozilla,

Have anybody analyze this problem?
Salva, can you take a look?  This seems like a regression from v1.0.1.
blocking-b2g: leo? → leo+
Flags: needinfo?(salva)
This is caused by bug 896848 which never landed in v1-train despite the several times we ask for its inclusion highlighting its low risk.
Flags: needinfo?(salva)
Depends on: 896848

Comment 6

4 years ago
Dear Salvador,

This issue is not save as 896848, because in our platform we have already import your patch.
The white screen of this issue is unable dispear by presss home_key or hold home_key, except you kill  usage from adb shell.

Updated

4 years ago
Flags: needinfo?(salva)

Comment 7

4 years ago
Dear All,

In attention_screen.js, only call ListMenu.hide() but not call listMenu.oncancel(), then in step 3, it will open app://wallpaper.gaiamobile.org/pick.html and app://costcontrol.gaiamobile.org/index.html, then cause error.

// Hide sleep menu/list menu if it is shown now
ListMenu.hide();
ListMenu.oncancel();//must have oncancle after hide.
SleepMenu.hide();
Flags: needinfo?(salva)
(In reply to Guoqiang.CHEN from comment #6)
> Dear Salvador,
> 
> This issue is not save as 896848, because in our platform we have already
> import your patch.

This has been totally unexpected. Per comment 7, it seems to be a system issue.

> The white screen of this issue is unable dispear by presss home_key or hold
> home_key, except you kill  usage from adb shell.

I know the consequences but I don't know why the app is not closing automatically.
No longer depends on: 896848

Comment 9

4 years ago
Sorry, should be this.
    if (typeof(ListMenu.oncancel) === 'function')
      ListMenu.oncancel();
Maybe visibility issue, taken to see what happens.
Assignee: nobody → alive
Not reproducible on v1.2 + v1.1, and I don't know why list_menu is related here.
qa-wanted.
Keywords: qawanted

Comment 12

4 years ago
Hi Alive,

You must long tap screen on idle screen to let wallpaper chooseActivity listMemu popup at first, 
then when a call in, will pop up the attention screen, it only hide listMenu, but not cancel it.
when open the data usage from the notification bar, it will call Activities->choose function .
but the first activities(about wallpater choise) info is still exist, so it will open app://wallpaper.gaiamobile.org/pick.html and app://costcontrol.gaiamobile.org/index.html, then an error occured.

Updated

4 years ago
QA Contact: sarsenyev

Comment 13

4 years ago
The bug reproduces on the latest Buri MOZ 1.1 RIL

1) Open the "Usage" app from the home screen
2) Go through the "Usage" "Registration" menu to register your data usage
3) Long tap the home screen (idle screen)
4) After "Select from" (Wallpaper, Galerry, Camera) page appears make a call to the testing device
5) Answer the call from the "idle" screen
6) End the call from the second device
7) Slide down the "Notification" menu
8) Tap the "Usage" bar
9) After the "Usage" screen opens press the home button

Actual result:
When pressing the "home button" white screen appears

Expected result:
A user is returned to the home screen

The issue doesn't reproduce on the latest Aurora 1.2 Buri build

Build ID: 20130926041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6f04a111aeb1
Gaia: d7309be553932635b7e6832d7471256824b5208f
Platform Version: 18.1
Keywords: qawanted
(In reply to Guoqiang.CHEN from comment #12)
> Hi Alive,
> 
> You must long tap screen on idle screen to let wallpaper chooseActivity
> listMemu popup at first, 
> then when a call in, will pop up the attention screen, it only hide
> listMenu, but not cancel it.
> when open the data usage from the notification bar, it will call
> Activities->choose function .
> but the first activities(about wallpater choise) info is still exist, so it
> will open app://wallpaper.gaiamobile.org/pick.html and
> app://costcontrol.gaiamobile.org/index.html, then an error occured.

OK, gotcha. A list menu issue I think. Patch incoming.
Created attachment 810961 [details]
https://github.com/mozilla-b2g/gaia/pull/12489/files

V1-train only patch: Cancel list menu on attention screen shows.
Attachment #810961 - Flags: review?(timdream)
Attachment #810961 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/53e2a70d85fb3748d0768218a5efffe5806073f0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g18: --- → fixed
Resolution: --- → FIXED
v1.1.0hd: 53e2a70d85fb3748d0768218a5efffe5806073f0
v1.1.0hd: ec7b420a3d83e9f7fa581c68ed0a5dbe95ee6324
status-b2g-v1.1hd: --- → fixed
(In reply to Alive Kuo [:alive] from comment #16)
> https://github.com/mozilla-b2g/gaia/commit/
> 53e2a70d85fb3748d0768218a5efffe5806073f0

If you uplifted this to v1-train, please remember that it needs to be uplifted to v1.2 as well.
You need to log in before you can comment on or make changes to this bug.