Closed Bug 916062 Opened 7 years ago Closed 7 years ago

Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/bounds/test_zoom.html | Exited with code 1 during test run| Assertion failure: JS_IsExceptionPending(cx) (JS failed without setting an exception!),

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 914939

People

(Reporter: cbook, Unassigned)

Details

(Keywords: assertion)

Crash Data

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-other on 2013-09-13 01:42:18 PDT for push 893512a52cfc

slave: talos-r4-snow-052

https://tbpl.mozilla.org/php/getParsedLog.php?id=27815988&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/bounds/test_zoom.html | Exited with code 1 during test run

Assertion failure: JS_IsExceptionPending(cx) (JS failed without setting an exception!), at ../../../../js/xpconnect/src/XPCWrappedJSClass.cpp:257

02:11:15  WARNING -  PROCESS-CRASH | chrome://mochitests/content/a11y/accessible/tests/mochitest/bounds/test_zoom.html | application crashed [@ nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject(JSContext*, JSObject*, nsID const&)]
02:11:15     INFO -  Crash dump filename: /var/folders/9k/9kHYv6MfHcm0ST+-9raloU+++-k/-Tmp-/tmpCW7YNS/minidumps/463CCB39-7FE9-46CB-8CA7-D841023C6818.dmp
02:11:15     INFO -  Operating system: Mac OS X
02:11:15     INFO -                    10.6.8 10K549
02:11:15     INFO -  CPU: amd64
02:11:15     INFO -       family 6 model 23 stepping 10
02:11:15     INFO -       2 CPUs
02:11:15     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
02:11:15     INFO -  Crash address: 0x0
02:11:15     INFO -  Thread 0 (crashed)
02:11:15     INFO -   0  XUL!nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject(JSContext*, JSObject*, nsID const&) [RootingAPI.h:893512a52cfc : 661 + 0x0]
02:11:15     INFO -      rbx = 0x00007fff70df62f8   r12 = 0x000000010013d680
02:11:15     INFO -      r13 = 0x00000001272de590   r14 = 0x00000001272de530
02:11:15     INFO -      r15 = 0x0000000103fdc300   rip = 0x00000001021f36c2
02:11:15     INFO -      rsp = 0x00007fff5fbfc380   rbp = 0x00007fff5fbfc4c0
02:11:15     INFO -      Found by: given as instruction pointer in context
02:11:15     INFO -   1  XUL!nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**) [XPCWrappedJSClass.cpp:893512a52cfc : 696 + 0x16]
02:11:15     INFO -      rbx = 0x00000001272de530   r12 = 0x00007fff5fbfc7d0
02:11:15     INFO -      r13 = 0x0000000103fdc354   r14 = 0x0000000149a48320
02:11:15     INFO -      r15 = 0x000000011f21d850   rip = 0x00000001021f4d4c
02:11:15     INFO -      rsp = 0x00007fff5fbfc4d0   rbp = 0x00007fff5fbfc6d0
02:11:15     INFO -      Found by: call frame info
02:11:15     INFO -   2  XUL!nsBindingManager::GetBindingImplementation(nsIContent*, nsID const&, void**) [nsBindingManager.cpp:893512a52cfc : 709 + 0xb]
02:11:15     INFO -      rbx = 0x0000000149a48330   r12 = 0x00000001492b6f60
02:11:15     INFO -      r13 = 0x000000012800b9d0   r14 = 0x00007fff5fbfc7d0
02:11:15     INFO -      r15 = 0x0000000103fdc354   rip = 0x0000000101bbcb0c
02:11:15     INFO -      rsp = 0x00007fff5fbfc6e0   rbp = 0x00007fff5fbfc7b0
02:11:15     INFO -      Found by: call frame info
02:11:15     INFO -   3  XUL!nsXULElement::QueryInterface(nsID const&, void**) [nsXULElement.cpp:893512a52cfc : 350 + 0x16]
02:11:15     INFO -      rbx = 0x00007fff5fbfc810   r12 = 0x0000000103fdc354
02:11:15     INFO -      r13 = 0x00000001492b6f60   r14 = 0x00000001492b6f60
02:11:15     INFO -      r15 = 0x00000001492b6f60   rip = 0x00000001020477e5
02:11:15     INFO -      rsp = 0x00007fff5fbfc7c0   rbp = 0x00007fff5fbfc800
02:11:15     INFO -      Found by: call frame info
02:11:15     INFO -   4  XUL!mozilla::a11y::XULSelectControlAccessible::XULSelectControlAccessible(nsIContent*, mozilla::a11y::DocAccessible*) [nsCOMPtr.h:893512a52cfc : 1199 + 0x4]
02:11:15     INFO -      rbx = 0x000000012b75c8f0   r12 = 0x0000000000000000
02:11:15     INFO -      r13 = 0x00000001492b6f60   r14 = 0x00000001492b6f60
02:11:15     INFO -      r15 = 0x00000001272fb770   rip = 0x00000001010df213
02:11:15     INFO -      rsp = 0x00007fff5fbfc810   rbp = 0x00007fff5fbfc830
02:11:15     INFO -      Found by: call frame info
Tip, search for the signature before filing a new bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 914939
You need to log in before you can comment on or make changes to this bug.