Closed Bug 916068 Opened 7 years ago Closed 7 years ago

Can't change timezone if we are not connected to a voice network

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:hd+, b2g-v1.1hd fixed, b2g-v1.2 fixed)

VERIFIED FIXED
blocking-b2g hd+
Tracking Status
b2g-v1.1hd --- fixed
b2g-v1.2 --- fixed

People

(Reporter: hub, Assigned: timdream)

References

Details

(Keywords: regression)

Attachments

(1 file)

I just reflashed my inari with today master.

In the FTE, Date & Time, the timezone is set to GMT. When I tap the top "change" button I get an empty list. Same for the one next to "GMT".
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Keywords: regression
blocking-b2g: --- → koi?
Assignee: nobody → sparsons
Assignee: sparsons → nobody
QA Contact: sparsons
This issue was reproduced as far back as the 8/28 Build ID: 20130828040202. It seems as though it can only  be reproduced when there is no SIM inserted in the device.

Environmental Variables
Build ID: 20130828040202
Gecko: http://hg.mozilla.org/mozilla-central/rev/416075f77249
Gaia: eb48d3682e045c94b650323b5a55898afdf3e3b1
Platform Version: 26.0a1
RIL Version: 01.02.00.019.043 


Last working on Buri 1.2 Build ID: 20130827040201

Environmental Variables
Build ID: 20130827040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e42dce3209da
Gaia: 599214a0f41eece076dc83cd85f5b27f8cfe67f2
Platform Version: 26.0a1
RIL Version: 01.02.00.019.043
Actually that phone has a SIM card, but it is disabled (settings show "????"). (it is one of the SIM card from TEF that we got in Madrid)
Interesting, we are using AT&T SIM's and can only repro when no SIM is inserted... 

(In reply to Hubert Figuiere [:hub] from comment #2)
> Actually that phone has a SIM card, but it is disabled (settings show
> "????"). (it is one of the SIM card from TEF that we got in Madrid)
(In reply to Sarah Parsons from comment #3)
> Interesting, we are using AT&T SIM's and can only repro when no SIM is
> inserted... 

But as I said, I suspect the SIM card has been disabled by the carrier.
Duplicate of this bug: 923775
As I investigated and documented in bug 923775, this is due to the fact tz.json is not copied into application.zip.

This bug affects Settings app too.
Component: Gaia::First Time Experience → Gaia
Summary: Can't change timezone → Can't change timezone on FTU and Settings app
Yuren, according to regression range, this might be a regression from bug 905096.
Flags: needinfo?(yurenju.mozilla)
OK, bug 905096 doesn't look like to be the offending commit....
Flags: needinfo?(yurenju.mozilla)
Wait, maybe missing json files is not the cause.
OK, the error I got is:
[JavaScript Error: "TypeError: conn.voice.network is null" {file: "app://settings.gaiamobile.org/shared/js/tz_select.js" line: 43}]

which I can fix. I am not sure if there are other causes, but I am going to submit a patch on this bug.
Summary: Can't change timezone on FTU and Settings app → Can't change timezone if we are not connected to a voice network
Assignee: nobody → timdream
Attached patch PatchSplinter Review
Due to Summit I am flagging anyone on the Settings app module and see how response first. This is really trivial.

Triage: this should be koi+ because w/o this patch devices w/o telephony will not be able to switch timezones.
Attachment #813987 - Flags: review?(kaze)
Attachment #813987 - Flags: review?(ehung)
Attachment #813987 - Flags: review?(arthur.chen)
One the other hand, I might have a phone with a broken RIL ... but I think our code should be more resistant to API breakage.
Duplicate of this bug: 911917
Comment on attachment 813987 [details] [diff] [review]
Patch

r=me, thanks for picking the JS error and fixing it.

Clear other review flags.
Attachment #813987 - Flags: review?(kaze)
Attachment #813987 - Flags: review?(ehung)
Attachment #813987 - Flags: review?(arthur.chen)
Attachment #813987 - Flags: review+
koi+ because of bug 916068 is marked so.
blocking-b2g: koi? → koi+
Uplifted c3cc92096f408e12ea65dc95e08a0f5a4c19fdb0 to:
v1.2: e96514bc8a47669f523a5abe724b3834cefeb0f9
blocking-b2g: koi+ → hd+
Duplicate of this bug: 925506
Hi Tim,

As discussed this needs to land on HD+ too for the duped bug 925506
Flags: needinfo?(timdream)
v1.1.0hd: c829a2042594b6c3a4899ee27979799a0f301534
Flags: needinfo?(timdream)
[2013/10/21 Helix Testing]
Gaia:     c829a2042594b6c3a4899ee27979799a0f301534
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f7c657f6d019
BuildID   20131015042201
Version   18.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.