[Keyboard][V1.2] Cannot change the keyboard layout between different built-in keyboards

RESOLVED DUPLICATE of bug 911129

Status

Firefox OS
Gaia::Keyboard
RESOLVED DUPLICATE of bug 911129
4 years ago
4 years ago

People

(Reporter: whsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FT:System-Platform], [Sprint:4], burirun1)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 804401 [details]
Keyboard - Switch keyboard via global key

* Description:
  If user switches the keyboard between different built-in keyboards, the keyboard layout cannot be changed.
  Attaching video.

* Reproduction steps:
  Note: Need to activate one third party keyboard layout and 2 built-in keyboard layouts.

  1. Launch message app
  2. Tap "Pencil" icon to edit a text message
  3. Tap text field to launch keyboard
  4. Long press the global key
  5. After the keyboard selection page pops up, please select a keyboard.

* Expected result:
  FxOS changes the keyboard layout

* Actual result:
  The keyboard layout is still the same.

* Reproduction build:(Mozilla-Central-2013-09-09-19-58-43)
  + Mercurial-Information
    - Gecko revision="740094c07328"
  + Git-information
    - Gaia revision="753bed59566ad14c5e032e45d2b320ef9529ca9a"
  + Gecko version: 26.0a1
(Reporter)

Updated

4 years ago
blocking-b2g: --- → koi?
Whiteboard: [FT:System-Platform], [Sprint:4]

Comment 1

4 years ago
A note:
It might be caused by focus losing when the layout menu popup.
It will get recovery if I click the text field after step 5.
OS: Gonk (Firefox OS) → iOS 3

Updated

4 years ago
OS: iOS 3 → Gonk (Firefox OS)
I think bug 911129 can fix this issue, so I set duplicate first.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911129
(Reporter)

Updated

4 years ago
Depends on: 891673
Whiteboard: [FT:System-Platform], [Sprint:4] → [FT:System-Platform], [Sprint:4], burirun1

Updated

4 years ago
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.