Change the default for layers to buffer rotation form tiling because of power consumption implications

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: milan, Assigned: milan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Currently tiling+shmem means no gralloc, means no hardware composer, means too much power.  As we consider bug 915673, turn back to buffer rotation+gralloc to let JB HWC work continue.
(Assignee)

Comment 1

5 years ago
Created attachment 804472 [details] [diff] [review]
Turn the tiling off

To not mess up the power consumption numbers and JB HWC work, turn the tiling back off for now.
Attachment #804472 - Flags: review?(blassey.bugs)
Comment on attachment 804472 [details] [diff] [review]
Turn the tiling off

Review of attachment 804472 [details] [diff] [review]:
-----------------------------------------------------------------

in layout/reftests/forms/input/range/reftest.list you'll need to mark the step-down tests (lines 22 and 23) as fails-if B2G
Attachment #804472 - Flags: review?(blassey.bugs) → review+
What bug regressed this that should be noted in "Blocks:" -- was it the layer refactoring metabug?

/be
(Assignee)

Comment 4

5 years ago
It's QC reported power consumption issue because hardware composer isn't being used.  There was no functional regression that we know of.
(Assignee)

Updated

5 years ago
See Also: → bug 887819
(Assignee)

Updated

5 years ago
Blocks: 911391
(Assignee)

Comment 5

5 years ago
Created attachment 804518 [details] [diff] [review]
Turn the tiling off

Waiting on try: https://tbpl.mozilla.org/?tree=Try&rev=dc2deb744fa2
Attachment #804472 - Attachment is obsolete: true
Attachment #804518 - Flags: review?(blassey.bugs)
(Assignee)

Comment 6

5 years ago
Comment on attachment 804518 [details] [diff] [review]
Turn the tiling off

Carry r+ from the original patch, waiting for try results before landing.
Attachment #804518 - Flags: review?(blassey.bugs) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/b2g-inbound/rev/3e27a204c850
Assignee: nobody → milan
Keywords: checkin-needed
After disabling tiling on b2g, we should not enable it until we confirmed that the tiling do not regress the important use cases(home screen, video playback, mail edit). Low power consumption is one of the most important competitive features.

Updated

5 years ago
Blocks: 916264
https://hg.mozilla.org/mozilla-central/rev/3e27a204c850
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Blocks: 915868

Updated

4 years ago
No longer depends on: 957276
You need to log in before you can comment on or make changes to this bug.