Closed Bug 916119 Opened 7 years ago Closed 7 years ago

Run mochitests on B2G Desktop builds

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: catlee, Assigned: ahal)

References

Details

(Whiteboard: [b2g][mozharness])

Attachments

(1 file)

We need to start running mochitests on B2G desktop builds (opt and debug)

We can run all tests on the linux64 builds, and perhaps some subset on other platforms. jgriffin mentioned perhaps skipping domlevel0/2 on mac/windows.

Debug builds are being stood up in bug 916111, but we can get started on testing the opt builds now.
Depends on: 916349
Depends on: 917055
I'll look into the mozharness side of things. I'll file new bugs to actually schedule tests when the mozharness script is done.
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Whiteboard: [b2g] → [b2g][mozharness]
Ahal, how is that mozharness script going? I'd love to be able to land the script and run mochitests by next week on cedar. It'd be really nice to establish a good cadence of these moving forward since there are so many to do this quarter.
Flags: needinfo?(ahalberstadt)
Blocks: 920354
(In reply to Clint Talbert ( :ctalbert ) from comment #2)
> Ahal, how is that mozharness script going? I'd love to be able to land the
> script and run mochitests by next week on cedar. It'd be really nice to
> establish a good cadence of these moving forward since there are so many to
> do this quarter.

Yep, the script is mostly finished, just doing some local testing and it should be ready for cedar and ash soon. In the meantime I filed bug 920354 to get the ball rolling for when this is done.
Flags: needinfo?(ahalberstadt)
Depends on: 920718
I think the mozharness script is more or less correct, but the b2g desktop runs are failing with the "TypeError: Container is null" message [1] when running with a tinderbox official build. If I point the exact same set up that the mozharness script creates at a local build, it works fine. For the record the local mozconfig I used is [2] and the official one is [3] (I think). I believe the problem is that the b2g desktop builds don't have tests enabled.

Anyway, I'm almost certain this won't be the only issue. But this patch works locally (aside from the above error) so I think we should get it reviewed and landed and then tackle any other errors we come across in follow up patches.

[1] http://pastebin.mozilla.org/3152269
[2] http://pastebin.mozilla.org/3152271
[3] http://mxr.mozilla.org/mozilla-central/source/b2g/config/mozconfigs/linux64_gecko/nightly
Attachment #810744 - Flags: review?(aki)
Depends on: 921180
Comment on attachment 810744 [details] [diff] [review]
Patch 1.0 - create b2g desktop mochitest mozharness script

From pyflakes:
scripts/b2g_desktop_unittest.py:14: 'TarErrorList' imported but unused
scripts/b2g_desktop_unittest.py:21: 'LogcatErrorList' imported but unused

> Anyway, I'm almost certain this won't be the only issue. But this patch
> works locally (aside from the above error) so I think we should get it
> reviewed and landed and then tackle any other errors we come across in
> follow up patches.

WFM.
Attachment #810744 - Flags: review?(aki) → review+
Fixed imports and merged to production: https://hg.mozilla.org/build/mozharness/rev/506407a6e8ee
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Progress update: This landed and is scheduled on cedar and ash. There's a problem with how utilityPath is being passed in which I am debugging on ash.
Depends on: 951771
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.