Closed Bug 916121 Opened 7 years ago Closed 6 years ago

outlook.com now supports IMAP

Categories

(Webtools :: ISPDB Database Entries, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: BenB, Assigned: BenB)

References

Details

Attachments

(1 file)

http://blogs.office.com/b/microsoft-outlook/archive/2013/09/12/outlook-com-now-with-imap.aspx

Microsoft just added IMAP support to outlook.com, and publicly citing Thunderbird (among others) and strong user demand as reasons.

I'd like to express a big THANK YOU to Microsoft for that.

And I'd like to thank them by swiftly adding it to the ISPDB. Patch follows.

Unfortunately, I can't test, only verify the server responding.
Duplicate of this bug: 915921
Summary: Upgrade outlook.com to IMAP → outlook.com now supports IMAP
http://windows.microsoft.com/en-US/windows/outlook/send-receive-from-app
* IMAP imap-mail.outlook.com 993, normal SSL
* POP3 pop-mail.outlook.com 995, normal SSL
* SMTP smtp-mail.outlook.com 587, STARTTLS

HOWEVER, the certs are for *.hotmail.com, so we'd get a cert alert. Bad. I haven't found a hostname at .hotmail.com that would match *-mail.outlook.com.

OTOH, that gives me hope that hotmail might soon get IMAP as well, or already support it unannouced.
Attached file outlook.com, v1
* Verified all hostnames and ports
* SSL cert is wrong, as mentioned
* Outlook.com docs specifically mention that POP3 deletes have effect
  on the main inbox on webmail and IMAP, so enable POP3 "leave on server"
* Use plaintext password (but with SSL)
Assignee: nobody → ben.bucksch
Status: NEW → ASSIGNED
Attachment #804553 - Flags: review?(bwinton)
Attachment #804553 - Flags: review?(gozer)
I don't want to be a pain Ben,  but it was my intent to change all of hotmail.  There is no real differentiation between Hotmail/msn/live or outlook.com as far as the folk at Microsoft are concerned.  While I think the upgrade to outlook.com requires you to log in from the web, I think the upgrade is all about the web app. There never has been separate servers or protocols for the differing domain names, each being a superset of those proceeding it.

My personal email addresses are @hotmail.com.
1. They work with IMAP.
2. There is no certificate alert.
3. Deleting mail, using pop at least, moves mail to the POP folder.  In IMAP this appears as a sub folder of deleted, but in the web interface this is not shown as related to deleted at all,  being a top level folder.

I tried viewing the patch,  but Bugzilla and my windows installation are determined in in a COM file and try and execute it.

Note that for years periodically hotmail.com servers have responded with a pophm.sympatico.ca cert (rather disconcerting the first time. Australia is rather a long way from Canada) and the requisite certificate error. In the last six months they have also offered up debug-pop3.live.com.  So no one should be surprised if SSL certificates once again trip them up.
Thanks, Matt, that's useful information. Which exact server config (hostnames, port, auth type, username form etc.) did you use for your hotmail.com account?

I'd be very happy, if all of hotmail could now use IMAP.
Attachment #804553 - Flags: review?(gozer) → review+
Comment on attachment 804553 [details]
outlook.com, v1

I'm sorry, I thought I reviewed this already…

All my objections were answered in IRC or in other bugs, so r=me.  :)

Thanks,
Blake.
Attachment #804553 - Flags: review?(bwinton) → review+
Commited as SVN Revision 119944
FIXED
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I filed bug 917035 about Matt's comment 4 that this works for all hotmail accounts.
I have updated the old bug 543227 because we have some negative feedback on French forums as users doesn't understand why they see English names for their Junk and Trash folders.
Attachment #804553 - Attachment mime type: application/x-msdos-program → text/plain
Reopening as the fix did not include Hotmail.com.  IMAP is supported in all Hotmail locales.

I have been using 
(imap) imap-mail.outlook.com:993	SSL/TLS	Normal password	smtp-mail.outlook.com:587	STARTTLS	Normal password	true

since I filled the bug that was duped to this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See comment 8
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.