bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

tcheck2 regression on Android caused by bug 912806

RESOLVED FIXED in Firefox 28



Firefox for Android
5 years ago
4 years ago


(Reporter: kats, Assigned: kats)


Firefox 28
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)


bug 912806 caused a regression in talos tcheck2 scores. This was known at the time bug 912806 landed, but that bug fixed a more important visual regression so I landed it anyway (see bug 912806 comment 27).

I don't believe that this is an actual regression, but that some of the resolution changes affect how the score for this test is reported. My first guess would be to check the code in ComputeRenderIntegrity to see if it uses the resolution or composition bounds and if that needs to be updated.
Also for the record bug 912806 did *not* regress eideticker. In fact it improved eideticker checkerboarding scores, as expected (since it fixed a previous checkerborading regression). See bug 915387 which was filed for the eideticker regression and is now fixed. This adds weight to my theory that this tcheck2 regression is just a measurement change with no user-visible impact.

Comment 2

5 years ago
I was just about to file a bug for this because I noticed that although my patches for bug 913683 appear to have brought tpan numbers back down, they did not fix tcheck2 at all. In fact, they seem to have reduced noise on 2.2 and made the tcheck2 numbers consistently higher, so maybe there is some real regression here. Either that, or this test is just incorrect.

Bug 732971 has now brought this back down to previous levels (and maybe even a bit lower).
Last Resolved: 4 years ago
Depends on: 732971
Resolution: --- → FIXED
Assignee: nobody → bugmail.mozilla
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.