Opening tiff images starts opening news windows until stopped

RESOLVED DUPLICATE of bug 88692

Status

()

RESOLVED DUPLICATE of bug 88692
17 years ago
17 years ago

People

(Reporter: bugs, Assigned: pavlov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I've found an article ( http://www.bnl.gov/bnlweb/pubaf/pr/bnlpr071801.htm )
linked from Slashdot, where clicking on the "Click to enlarge" links with middle
button or selecting Open Link in New Window from the popup menu opens up a new
window and starts getting the image as expected. But instead of displaying it or
asking what action should Mozilla do, it pops up another full browser window,
which pops up another, and so on until I close them.

I think it should replicate the behavior of the left-click, with the only
difference of one additional browser window. 

It could be the same problem with mime types that mozilla doesn't handle
internally, and on all platforms.

Found on: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628
-> imglib

Its a tiff, which we don't handle.
From previous times this has happened, something
(http://lxr.mozilla.org/seamonkey/source/uriloader/exthandler/nsExternalHelperAppService.cpp#113,
perhaps?) is claming that we know how to handle tiff, but its not being
registered in the category manager. Or the other way arround. Or something like
that...
Assignee: pchen → pavlov
Status: UNCONFIRMED → NEW
Component: XP Apps → ImageLib
Ever confirmed: true
QA Contact: sairuh → tpreston

Comment 2

17 years ago
dupe of bug 80931?
(Reporter)

Comment 3

17 years ago
Yes, but left clicking the links in bug 80931 works correctly, only middle
clicking/opening link in new window starts opening new windows. 
(Assignee)

Comment 4

17 years ago
dup of bug 88692

*** This bug has been marked as a duplicate of 88692 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.