Bug 916204 (apis-in-workers)

Norway Worker Work

RESOLVED FIXED

Status

()

Core
DOM: Workers
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: dougt, Assigned: overholt)

Tracking

(Depends on: 3 bugs, Blocks: 1 bug, {meta})

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
Component: DOM → DOM: Workers
(Reporter)

Updated

4 years ago
Assignee: nobody → doug.turner

Updated

4 years ago
Depends on: 874502

Comment 1

4 years ago
[https://wiki.mozilla.org/FirefoxOS/Haida] mentions this bug under "Shared Workers". I'm a bit confused on what the relationship to Bug 643325 is. Is this a dependency, synonymous to or dupe of, or orthogonal to Bug 643325?
(Reporter)

Comment 2

4 years ago
florian, this is my tracking bug so that we get everything done we promised to get done.  bug 643325 may be a dependency of this bug.
(Assignee)

Updated

4 years ago
Assignee: doug.turner → overholt
(Assignee)

Comment 3

4 years ago
More info including prioritized list of APIs to enable on workers:

https://etherpad.mozilla.org/WorkerThreadAPIs

- Game APIs
  - WebGL Canvas Bug 709490 http://wiki.whatwg.org/wiki/CanvasInWorkers
  - WebAudio
- IndexedDB Bug 701634
- console.* Bug 620935
- Promises Bug 915233
- Data Store
- Device Storage
- TCPSocket
- Notifications Bug 916893
- WebSocket Bug 504553
- MessageChannel
- Sync message channel
- FormData
- File System
- doNotTrack
- Parts of WebRTC (ask ekr)
- DataChannel
- 2D Canvas for workers (spec unstable) Bug 801176

Comment 4

4 years ago
From this list:

* Web Audio will require spec work -- that's not something that we can do right now.
* DataStore and TCPSocket (at least) are implemented in JS, which complicates things.
* WorkerNavigator.onLine is needed for some of our offline use cases (bug 925437).
Depends on: 925437
(Reporter)

Comment 5

4 years ago
Fwiw, not all of these APIs are required for end of year.  Ehsan - can you find out exactly what is needed for the gaia demos?
(Assignee)

Comment 6

4 years ago
I meant to ask you what you intended this bug to be, Doug:  APIs required for MWC demos or APIs gaia needs on workers in general.  I guess the latter is silly.

AFAIK async IDB is #1 and gaia can probably work around the others for their MWC demos.

Comment 7

4 years ago
(In reply to comment #5)
> Fwiw, not all of these APIs are required for end of year.  Ehsan - can you find
> out exactly what is needed for the gaia demos?

Sure, will do!

Comment 8

4 years ago
Vivien told me that the two big things that Gaia needs for the MWC demos are IndexedDB and DataStore.  The latter can be difficult since it's implemented in JS...
Alias: apis-in-workers
Depends on: 949325
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.