Lock and camera buttons are not available with explore by touch in screen reader

VERIFIED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: eeejay, Assigned: yzen)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
This has to do with the fact that #lockscreen-icon-container has pointer-events set to none.
(Assignee)

Updated

5 years ago
Assignee: nobody → yura.zenevich
(Assignee)

Comment 1

5 years ago
Created attachment 814283 [details] [diff] [review]
Github pull request.
Attachment #814283 - Flags: review?(eitan)
(Reporter)

Comment 2

5 years ago
Comment on attachment 814283 [details] [diff] [review]
Github pull request.

This looks good to me. Forwarding review to module owner.
Attachment #814283 - Flags: review?(timdream)
Attachment #814283 - Flags: review?(eitan)
Attachment #814283 - Flags: feedback+
(Reporter)

Comment 3

5 years ago
Comment on attachment 814283 [details] [diff] [review]
Github pull request.

Reverting my feedback after testing. Looks like the areas could be directly clicked now when not in screen reader mode. That should not happen.
Attachment #814283 - Flags: feedback+ → feedback-
Comment on attachment 814283 [details] [diff] [review]
Github pull request.

Removing r? because of f-. Please ask :snowmantw (gweng@mozilla.com) for review afterward.

We will probably need to figure out a way to test screen reader before r+'ing this bug (instead of asking eitan to verify it).
Attachment #814283 - Flags: review?(timdream)
(Assignee)

Comment 5

5 years ago
Created attachment 815728 [details] [diff] [review]
Github pull request v2.
Attachment #814283 - Attachment is obsolete: true
Attachment #815728 - Flags: review?(gweng)
Attachment #815728 - Flags: feedback?(eitan)
On the simulator the only difference I can see is the icon now can't be clicked to lighten when I turn off the Screen Reader (of course it's the result in UX, not what we really concern). If I enable it and use the navigation tools to move on the icon and click on it, no matter which mode I was in, the behavior seems no difference.

So maybe as Tim said, it's better to wait a way to test screen reader, and I really need some feedback.
(Reporter)

Comment 7

5 years ago
(In reply to Greg Weng [:snowmantw] from comment #6)
> On the simulator the only difference I can see is the icon now can't be
> clicked to lighten when I turn off the Screen Reader (of course it's the
> result in UX, not what we really concern). If I enable it and use the
> navigation tools to move on the icon and click on it, no matter which mode I
> was in, the behavior seems no difference.

Besides the linear navigation in the screen reader, there is also a feature called "explore by touch" that allows the user to highlight an object by putting their finger over it. That doesn't currently work for the lockscreen buttons in gaia master.

> 
> So maybe as Tim said, it's better to wait a way to test screen reader, and I
> really need some feedback.

It sounds like you were able to use the screen reader, no? If not there are two option. The last two sections of this post explain how:
http://blog.monotonous.org/2013/10/09/an-introduction-to-making-firefox-os-apps-accessible/
(Assignee)

Updated

5 years ago
Attachment #815728 - Flags: feedback?(eitan)
(Assignee)

Comment 8

5 years ago
I updated the pull request and the icons now lighten on click as before.
Flags: needinfo?(gweng)
Comment on attachment 815728 [details] [diff] [review]
Github pull request v2.

Thanks Eitan's guide. I've tested the patch and it works fine, so I would grant it. However, may Yura can push it to GitHub again to pass the test before merge it. It's currently broken due to a irrelevant error, and maybe rerunning the test can solve it.
Attachment #815728 - Flags: review?(gweng) → review+
Flags: needinfo?(gweng)
(Assignee)

Comment 10

5 years ago
Pushed again as requested.
Flags: needinfo?(gweng)
The alarm failed as I heard in these days...
Nevertheless, Yura, please merge it, thanks.
Flags: needinfo?(gweng)
(Reporter)

Comment 12

5 years ago
https://github.com/mozilla-b2g/gaia/commit/0fea8a6492c5795ec6e2799c0b65cb61fc86e3b4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified in latest Gaia Master.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 920195
You need to log in before you can comment on or make changes to this bug.