Closed Bug 916310 Opened 8 years ago Closed 8 years ago

browser/base/content/test/browser_aboutHealthReport.js | Console message: [JavaScript Error: "DEPRECATION WARNING: Field 'creationDate' is deprecated

Categories

(Firefox Health Report Graveyard :: Data Collection, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 916186

People

(Reporter: mats, Unassigned)

References

Details

(I can't find the component for Health Report so please forward as needed)

This test generates a lot of warnings in the mochitest logs:

10:04:57     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_aboutHealthReport.js | Console message: [JavaScript Error: "DEPRECATION WARNING: Field 'creationDate' is deprecated.
10:04:57     INFO -  You may find more details about this deprecation at: https://developer.mozilla.org/en-US/docs/JavaScript_OS.File/OS.File.Info#Cross-platform_Attributes
10:04:57     INFO -  resource://gre/modules/osfile/osfile_async_front.jsm 754 creationDate
10:04:57     INFO -  resource://gre/modules/HealthReport.jsm 6657 iterateDirectory
10:04:57     INFO -  resource://gre/modules/Task.jsm 233 TaskImpl_run
10:04:57     INFO -  resource://gre/modules/Promise.jsm 572 null
10:04:57     INFO -  resource://gre/modules/Promise.jsm 354 null
10:04:57     INFO -  null 0 null
10:04:57     INFO -  " {file: "resource://gre/modules/Deprecated.jsm" line: 79}]
10:04:57     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_aboutHealthReport.js | Console message: [JavaScript Error: "DEPRECATION WARNING: Field 'creationDate' is deprecated.
10:04:57     INFO -  You may find more details about this deprecation at: https://developer.mozilla.org/en-US/docs/JavaScript_OS.File/OS.File.Info#Cross-platform_Attributes
10:04:57     INFO -  resource://gre/modules/osfile/osfile_async_front.jsm 754 creationDate
10:04:57     INFO -  resource://gre/modules/HealthReport.jsm 6657 iterateDirectory
10:04:57     INFO -  resource://gre/modules/Task.jsm 233 TaskImpl_run
10:04:57     INFO -  resource://gre/modules/Promise.jsm 572 null
10:04:57     INFO -  resource://gre/modules/Promise.jsm 354 null
10:04:57     INFO -  null 0 null
10:04:57     INFO -  " {file: "resource://gre/modules/Deprecated.jsm" line: 79}]
10:04:57     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_aboutHealthReport.js | Console message: [JavaScript Error: "DEPRECATION WARNING: Field 'creationDate' is deprecated.
10:04:57     INFO -  You may find more details about this deprecation at: https://developer.mozilla.org/en-US/docs/JavaScript_OS.File/OS.File.Info#Cross-platform_Attributes
10:04:57     INFO -  resource://gre/modules/osfile/osfile_async_front.jsm 754 creationDate
10:04:57     INFO -  resource://gre/modules/HealthReport.jsm 6657 iterateDirectory
10:04:57     INFO -  resource://gre/modules/Task.jsm 233 TaskImpl_run
10:04:57     INFO -  resource://gre/modules/Promise.jsm 572 null
10:04:57     INFO -  resource://gre/modules/Promise.jsm 354 null
10:04:57     INFO -  null 0 null
10:04:57     INFO -  " {file: "resource://gre/modules/Deprecated.jsm" line: 79}]
10:04:57     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_aboutHealthReport.js | Console message: [JavaScript Error: "DEPRECATION WARNING: Field 'creationDate' is deprecated.
10:04:57     INFO -  You may find more details about this deprecation at: https://developer.mozilla.org/en-US/docs/JavaScript_OS.File/OS.File.Info#Cross-platform_Attributes
10:04:57     INFO -  resource://gre/modules/osfile/osfile_async_front.jsm 754 creationDate
10:04:57     INFO -  resource://gre/modules/HealthReport.jsm 6657 iterateDirectory
10:04:57     INFO -  resource://gre/modules/Task.jsm 233 TaskImpl_run
10:04:57     INFO -  resource://gre/modules/Promise.jsm 572 null
10:04:57     INFO -  resource://gre/modules/Promise.jsm 354 null
10:04:57     INFO -  null 0 null

... etc ...
Mike, can you take a look?
Usage of creationDate was introduced by bug 808126. Can that usage just be removed?

Discussed this a bit with Yoric on IRC, and creationDate was deprecated because it's both only available on OSX and Windows (properties are now macBirthDate/winBirthDate), and is unreliable on the platforms it is available on (depends on the filesystem).

The usage here seems redundant - its recording the creation date and last-modified date of crash dump files. AFAIK, dump files aren't touched after they've been first written - so just last-modified date should be adequate to record (and that date is reliable).
Blocks: 808126
Flags: needinfo?(gps)
Component: General → Data Collection
Product: Firefox → Firefox Health Report
I think this counts as a dupe of Bug 916186.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 916186
Flags: needinfo?(gps)
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.