If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Helix][Freeze][denghuachang]Screen freezed during monkey test

RESOLVED INVALID

Status

Firefox OS
General
P1
normal
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

[probability]
low, about 5%

[repro steps]
USB connected, running monkey test


Actual results:

Actual results:
During monkey test, screen freezed and no response during monkey test


Expected results:

Expected results:
During monkey test, there is no abnormal. After Monkey test, the device still can work well. 

[Question]
Once freeze happened, how to collect the useful logs and efficient debug methods?
(Reporter)

Updated

4 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P1
(Reporter)

Updated

4 years ago
Flags: needinfo?(wchang)
There is no information indicating this being a different problem than bug 908610. And no valid debugging information here. Duping
Severity: blocker → normal
Status: UNCONFIRMED → RESOLVED
blocking-b2g: hd? → ---
Last Resolved: 4 years ago
Flags: needinfo?(wchang)
Resolution: --- → DUPLICATE
Duplicate of bug: 908610
(Reporter)

Updated

4 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Updated

4 years ago
Flags: needinfo?(wchang)
Created attachment 805983 [details]
logcat_kmsg.zip
Flags: needinfo?(wchang)
Comment 2 has logs from reporter sent in an email.

Alan, if you can check or ask someone that can if you'd be absent.

Thanks
Flags: needinfo?(ahuang)

Comment 4

4 years ago
The log doesn't indicate crash and can't show us what main thread and other IO thread are doing. 

Hi Lecky,
As our talk in August, please attach gdb and provide all b2g threads' back trace if you met a frozen screen. (The command should be "thread apply all bt")
Flags: needinfo?(ahuang) → needinfo?(lecky.wanglei)
(Reporter)

Comment 5

4 years ago
ok, I will try the method you mentioned
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(lecky.wanglei)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.