crash in nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool) message delete/undo

RESOLVED DUPLICATE of bug 873426

Status

--
critical
RESOLVED DUPLICATE of bug 873426
5 years ago
3 months ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme][rare], crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-0b2cdc46-95fb-4964-afa5-0cd0f2130810.
=============================================================
0		@0xc00ffa	
1	xul.dll	nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr *,bool)	mailnews/base/util/nsMsgDBFolder.cpp
2	xul.dll	nsMsgDBFolder::OnHdrAdded(nsIMsgDBHdr *,unsigned int,int,nsIDBChangeListener *)	mailnews/base/util/nsMsgDBFolder.cpp
3	xul.dll	nsMsgDatabase::NotifyHdrAddedAll(nsIMsgDBHdr *,unsigned int,int,nsIDBChangeListener *)	mailnews/db/msgdb/src/nsMsgDatabase.cpp
4	xul.dll	nsMsgDatabase::AddNewHdrToDB(nsIMsgDBHdr *,bool)	mailnews/db/msgdb/src/nsMsgDatabase.cpp
5	xul.dll	nsMsgLocalMailFolder::EndCopy(bool)	mailnews/local/src/nsLocalMailFolder.cpp
6	xul.dll	nsCopyMessageStreamListener::EndCopy(nsISupports *,unsigned int)	mailnews/base/src/nsCopyMessageStreamListener.cpp
7	xul.dll	nsCopyMessageStreamListener::OnStopRequest(nsIRequest *,nsISupports *,unsigned int)	mailnews/base/src/nsCopyMessageStreamListener.cpp
8	xul.dll	nsMsgProtocol::OnStopRequest(nsIRequest *,nsISupports *,unsigned int)	mailnews/base/util/nsMsgProtocol.cpp
9	xul.dll	nsMailboxProtocol::OnStopRequest(nsIRequest *,nsISupports *,unsigned int)	mailnews/local/src/nsMailboxProtocol.cpp
10	xul.dll	nsInputStreamPump::OnStateStop()	netwerk/base/src/nsInputStreamPump.cpp 

bp-c7ded2b8-6e69-4550-a6ff-8d9242130809
@0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Updated

3 years ago
Crash Signature: [@ nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)] [@ @0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)] → [@ nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)] [@ @0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)] [@ nsMsgDBFolder::OnHdrAddedOrDeleted] [@ @0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted]
(Reporter)

Comment 2

2 years ago
This could probably be combined with a bug with higher crash rate
Whiteboard: [dupme][rare]
(Reporter)

Comment 3

3 months ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> This could probably be combined with a bug with higher crash rate

bug 873426 appears to be related and more common
Status: NEW → RESOLVED
Crash Signature: [@ nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)] [@ @0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted(nsIMsgDBHdr*, bool)] [@ nsMsgDBFolder::OnHdrAddedOrDeleted] [@ @0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted] → [@ nsMsgDBFolder::OnHdrAddedOrDeleted ] [@ @0x0 | nsMsgDBFolder::OnHdrAddedOrDeleted ]
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873426
You need to log in before you can comment on or make changes to this bug.