If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail not showing up in Inbox (Inbox empty)

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
blocker
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Ashley Bischoff (blog at handcoding.com), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({dataloss})

Trunk
x86
Windows 2000
dataloss

Firefox Tracking Flags

(Not tracked)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2+)
Gecko/20010717
BuildID:    2001071704

I'm making an effort to switch to Mozilla from another mail client. So, I setup
the mail account and downloaded some mail. Mozilla goes through the motions
(asking me for password, downloading mail, etc), but the mail never appears in
my Inbox.

Reproducible: Always
Steps to Reproduce:
1. Download mail.


Actual Results:  Inbox is empty. Inbox's tooltip reads "Inbox (0/0)".

Expected Results:  Mail should appear in Inbox.

My account settings, in case any of this is out of the ordinary:

    Type: POP3
    Address: mozilla@handcoding.com
    Mail server: mail.handcoding.com

    Username: mozilla@handcoding.com (yes, you read that correctly, it really is
"mozilla@handcoding.com" and not "mozilla")

I wasn't certain about which Severity to select, but the description for
Critical reads "Mozilla crashes, hangs, leaks memory, or causes you to lose
data", which seemed applicable (the "lose data" part, that is).

FWIW, if I manually open the file "Inbox" on my HDD with Notepad, I can see the
mail -- it's just not showing up in Mozilla!
Adding keyword "dataloss".
Keywords: dataloss

Comment 2

16 years ago
Oooh, I think this is one of the "rare cases" we talked about in another bug,
Seth and Bhuvan.

His userid is something with @ in it, so the request that is sent out becomes
horked, I think.

CC bhuvan
Hwarra, bhuvan, and other developers: I own handcoding.com (the site cited in
the bug report). So, if anyone wants an e-mail address @handcoding.com for
testing purposes, just let me know (it's no problem). 

PS I'm Rembrandt on IRC, btw.
Changing to "blocker" since I am unable to use mailnews with this bug
("physically unable", as hwaara would say).
Severity: critical → blocker
I just sent mail to alex to get an account for testing.

Status: NEW → ASSIGNED
I've created an account for Seth. If any other developers want one, just let me
know.
this is working for me on the account that alex set up for me.

my username was sspitzer@handcoding.com, so it's not the "@" in the username.

alex, what happens if you create a new profile?

what happens if you exit the app, copy the Inbox file on disk to a file named
Foobar, and start back up.

do the messages show up when you click on the "Foobar" folder?
At Seth's advice, I tried a new profile, and that seemed to solve the problem.
Marking RESOLVED - FIXED.

However, I now have two profiles: one brand-new profile without any of my
settings or bookmarks (but a working mail client), and one fully-configured
profile (with a non-working mail client). 

Is there any method to import the settings of my old profile (the one without
working mail) into my newly-created profile?

While I'm on the subject of mail, I have another question: is there any means to
configure what happens when I press "Del" while a message is loaded in its own
window? Currently, the behavior seems to be that Mozilla just opens up the next
message, but I'd prefer Mozilla to *only* delete the next message (and not open
up the following message).
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Please file those as different bugs, since your original bug is working, going 
to verify this.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.