If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Actors are cached and no longer update when running xpcshell tests

RESOLVED DUPLICATE of bug 916874

Status

()

Firefox
Developer Tools: Debugger
RESOLVED DUPLICATE of bug 916874
4 years ago
4 years ago

People

(Reporter: ochameau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
For some reason, now I have to execute `$ rm /tmp/startupCache` before each run in order to have a sane behavior when running xpcshell tests!
Otherwise, actors (at least them, but other files like server/main.js behaves correctly) aren't updated and stay to an old version, typically the first test run after a reboot...

Could this be related to the switch to modules for the server?
This doesn't seem to happen for me on OS X. Modifying script.js results in xpcshell tests getting the changed code. The cache in ~/Library/Caches/TemporaryItems/startupCache seems a few days old, but it doesn't look like the test harness uses it.
(Reporter)

Comment 2

4 years ago
May be that's linux specific... Or I have something wrong in my environment...
I'm on Ubuntu 12.04.3 LTS.
I have the same results as Panos, as in I see changes to the actors immediately.  However, I am also on OS X, so could still be Linux specific.

I don't think the server loading changes are responsible.  After the compromise change in bug 911127, there shouldn't actually be any loading changes for the "main" usage of the debug server.  Only the Browser Debugger uses the require module loader version for now.  Hopefully we'll clean this up soon, so everyone is using the same loader path...  It's quite bad as it is now.
(Reporter)

Comment 4

4 years ago
Issue figured out in bug 916874.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 916874
You need to log in before you can comment on or make changes to this bug.