Download of a exe file (from Texas Instruments) fails due to mixed content

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Martin Maurer, Unassigned)

Tracking

23 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

When downloading files from Texas Instruments like
one of the patch programmers
http://processors.wiki.ti.com/index.php/CC3000_Wi-Fi_Downloads#Patch_Programmer
fails. Download does simply not start.
Even if it fails, you get an email with a link inside,
which also fails.
(Registration required, therefore i cannot share the link, 
because i don't know if my login/password is somehow in link...)
IE displays (i have a German version, translated by myself...)
first: "Only secure content is displayed - would you display complete content"
second: "Would you download or save ....exe" (EXE!)

I already tried to temporarily to switch off Popup-Blocker, Ad-Blocker, "Warn me when sites try to install add-on",
"Block report attack sites", "Block reported web forgeries". Still no success.
I also tried a nightly build from Firefox (which is one of the version 25), but no success.



Actual results:

Download fails with Firefox (but works with MSIE)
No download is started.


Expected results:

Download shall work with Firefox.
(Reporter)

Comment 1

5 years ago
Retested with Firefox 24.0 -> it is still not working
(Reporter)

Comment 2

5 years ago
Problem is solved!

Solution: Left beside the URL in Firefox, where usually the encrypted connection info is display, is a small icon, which says: "Content is blocked" - "Do you want to unblock it?" (not real wording, but something similar).

Suggestion: Perhaps you can make a popup, blinking icon, something else, 
which a normal user can recognize that Firefox has something for the user?
(i just got the hint by a another user, many thanks, i am using Firefox really long, 
but this was something new for me that there is more than info behind this small icon...)

Comment 3

5 years ago
TI should repair their website and avoid mixed content...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Summary: Download of a exe file (from Texas Instruments) fails → Download of a exe file (from Texas Instruments) fails due to mixed content
You need to log in before you can comment on or make changes to this bug.