Thunderbird profile data spread across multiple file folders in AppData in Windows

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: u212676, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.66 Safari/537.36

Steps to reproduce:

Thunderbird was loaded on my new laptop in 2011 running Windows 7. I don't remember the original version of Thunderbird installed, unless it can be found in a history file within Thunderbird related to updates. It created a profile in AppData Thunderbird > Roaming and Local. 


Actual results:

Thunderbird appears to use both file paths, but I do not roam, so don't know how that feature would be used.  Thunderbird does not store everything in one file path. It seems to be distributed across Local and Roaming with no particular logic.

The dilemma this creates is that when backing up the profile, what should one back up and which is the most important profile should a choice between stored profile locations have to be made?


Expected results:

Either duplicate the file structure in both paths, or make it more clear what ot back up when a recovery copy is needed.

A file structure can be provided if requested.

Comment 1

5 years ago
profile data is in %appdata%\Thunderbird\profiles
that's the only directory you need to back up.
ref http://support.mozillamessaging.com/en-US/kb/Profiles
nothing else matters

...\Local is required and use for cache. so not a bug, hence => invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.