unable to submit app

VERIFIED FIXED in 2013-09-17

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: eviljeff, Assigned: cvan)

Tracking

2013-09-17
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 805299 [details]
taksiproksi.zip

The developer says every time they try to upload this app they get 'unexpected server error while validating'
(Assignee)

Updated

5 years ago
Duplicate of this bug: 916900
From bug 916900 comment 0:

> Created attachment 805439 [details]
> taxiproxy.zip
> 
> From the developer:
> 
> Since before the end of Sunday evening (local CET time) I've been trying to,
> as an initial version of an app I'd like to further test and develop for the
> Firefox OS platform, upload it to your marketplace with no avail.
> 
> The error received after upload is non-explanatory:
> Your app failed validation with 1 error.
> Unexpected server error while validating.
Locally I get:

Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/wsgiref/handlers.py", line 93, in run
    self.result = application(self.environ, self.start_response)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/django/contrib/staticfiles/handlers.py", line 67, in __call__
    return self.application(environ, start_response)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/django/core/handlers/wsgi.py", line 241, in __call__
    response = self.get_response(request)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/django/core/handlers/base.py", line 179, in get_response
    response = self.handle_uncaught_exception(request, resolver, sys.exc_info())
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "/opt/zamboni/apps/amo/decorators.py", line 157, in wrapper
    return f(*args, **kw)
  File "/opt/zamboni/apps/amo/decorators.py", line 149, in wrapper
    return f(*args, **kw)
  File "/opt/zamboni/apps/amo/decorators.py", line 32, in wrapper
    return func(request, *args, **kw)
  File "/opt/zamboni/mkt/developers/views.py", line 471, in upload_new
    return _upload(*args, **kwargs)
  File "/opt/zamboni/apps/amo/decorators.py", line 51, in wrapper
    return f(request, *args, **kw)
  File "/opt/zamboni/mkt/developers/views.py", line 456, in _upload
    tasks.validator.delay(form.file_upload.pk)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/celery/app/task.py", line 358, in delay
    return self.apply_async(args, kwargs)
  File "/Users/chris/.virtualenvs/z/src/nuggets/celeryutils.py", line 22, in apply_async
    return super(Task, self).apply_async(args, kwargs, **options)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/celery/app/task.py", line 462, in apply_async
    return self.apply(args, kwargs, task_id=task_id, **options)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/celery/app/task.py", line 634, in apply
    request=request, propagate=throw)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/celery/task/trace.py", line 326, in eager_trace_task
    uuid, args, kwargs, request)
  File "/Users/chris/.virtualenvs/z/lib/python2.6/site-packages/celery/task/trace.py", line 228, in trace_task
    R = retval = fun(*args, **kwargs)
  File "/Users/chris/.virtualenvs/z/src/nuggets/celeryutils.py", line 35, in wrapped
    return fun(*args, **kw)
  File "/opt/zamboni/apps/amo/decorators.py", line 157, in wrapper
    return f(*args, **kw)
  File "/opt/zamboni/apps/amo/decorators.py", line 149, in wrapper
    return f(*args, **kw)
  File "/opt/zamboni/mkt/developers/tasks.py", line 57, in validator
    validation_result = run_validator(upload.path, url=kw.get('url'))
  File "/opt/zamboni/mkt/developers/tasks.py", line 116, in run_validator
    spidermonkey=settings.SPIDERMONKEY)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/validate.py", line 71, in validate_packaged_app
    submain.prepare_package(bundle, path, timeout)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/submain.py", line 63, in prepare_package
    test_package(err, package, path)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/submain.py", line 94, in test_package
    output = test_inner_package(err, package)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/submain.py", line 119, in test_inner_package
    test(err, package)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/content.py", line 75, in test_packed_packages
    processed = _process_file(err, package, name, file_data)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/content.py", line 105, in _process_file
    testendpoint_js.test_js_file(err, name, file_data)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/scripting.py", line 30, in test_js_file
    trav.run(tree)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 65, in run
    func()
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 155, in <lambda>
    traverser.function_collection[-1].append(lambda: wrap(traverser, node))
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 152, in wrap
    func()
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 155, in <lambda>
    traverser.function_collection[-1].append(lambda: wrap(traverser, node))
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 152, in wrap
    func()
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 155, in <lambda>
    traverser.function_collection[-1].append(lambda: wrap(traverser, node))
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 152, in wrap
    func()
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 155, in <lambda>
    traverser.function_collection[-1].append(lambda: wrap(traverser, node))
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 152, in wrap
    func()
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 155, in <lambda>
    traverser.function_collection[-1].append(lambda: wrap(traverser, node))
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 141, in wrap
    traverser._traverse_node(node["body"])
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 136, in _traverse_node
    map(self._traverse_node, b)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 138, in _traverse_node
    self._traverse_node(b)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 136, in _traverse_node
    map(self._traverse_node, b)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 116, in _traverse_node
    action_result = action(self, node)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/actions.py", line 450, in _expr_assignment
    member_object.value.set(member_property, right, traverser)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/jstypes.py", line 52, in set
    modified_value = modifier(value, traverser)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/instanceproperties.py", line 15, in set_innerHTML
    return _set_HTML_property("innerHTML", new_value, traverser)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/javascript/instanceproperties.py", line 53, in _set_HTML_property
    parser.process(traverser.filename, literal_value, "xul")
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/markup/markuptester.py", line 97, in process
    self._feed_parser(search_line)
  File "/Users/chris/.virtualenvs/z/src/app-validator/appvalidator/testcases/markup/markuptester.py", line 110, in _feed_parser
    except htmlparser.HTMLParseError as inst:
NameError: global name 'htmlparser' is not defined

Basta?
well that's a new one. will investigate.

Updated

5 years ago
Component: Developer Pages → Validation
https://github.com/mozilla/app-validator/commit/f5b2c40
https://github.com/mozilla/zamboni/commit/970f4ce3

You can test that it's fixed on -dev:
https://marketplace-dev.allizom.org/developers/submit/

Fix will go out tomorrow, Tues. 9/17, at 2.00 PDT.

Thanks, everyone, for your patience - and sorry about the bug!
Assignee: nobody → cvan
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-09-17

Comment 6

5 years ago
Thanks you all for the dev fix, I tested it, worked around the server exception.
Afterwards, had two minutes worth of small fixes like having to remove some Windows 8 MSApp object checking and dynamic jQuery loading code, alongside the need to remove out inline script tagged js code.
It got published onto dev (https://marketplace-dev.allizom.org/app/taksiproksi/) but I'm guessing the push to deployment is going out at 2PM PDT, since it's still not working around at marketplace.firefox.com...
Hope just Telenor Serbia accepts the delay now since technically, even though I was submitting the beta app before their competition deadline, it couldn't be published any earlier not exclusively due to my own fault.
Really would like to have a chance for at least winning an actual Firefox OS test device to further develop the app, adding stuff like the Here maps taxi fare calculator, similar to the http://taxiproxy.com/page/kalkulator page on the taxiproxy.com website (since the performance on the simulator is real good I'm unsure that'll be the case on the actual smartphone devices themselves).

Comment 7

5 years ago
P.S.
Could someone please either make the dev marketplace submission public and/or copy it to the regular marketplace since it seems the app submission is visible only to myself now, and I had sent an email to Telenor Serbia already, alongside that dev marketplace link.

Comment 8

5 years ago
I verified on -dev, but I get a validation error "Icon size does not match." with the app in the attachment. Could you please provide a valid app so we can verify this? Thank you! http://screencast.com/t/NCbCeaN7
Flags: needinfo?
(In reply to Iulian Timis from comment #8)
> I verified on -dev, but I get a validation error "Icon size does not match."
> with the app in the attachment. Could you please provide a valid app so we
> can verify this? Thank you! http://screencast.com/t/NCbCeaN7

The fact that it doesn't traceback should be fine to verify this. The app otherwise wouldn't complete the validation process.
Flags: needinfo?
(Reporter)

Comment 10

5 years ago
(In reply to dejan from comment #7)
> P.S.
> Could someone please either make the dev marketplace submission public
> and/or copy it to the regular marketplace since it seems the app submission
> is visible only to myself now, and I had sent an email to Telenor Serbia
> already, alongside that dev marketplace link.

I'm afraid it can't be copied to production Marketplace and it won't be reviewed on dev Marketplace - its only used for testing.  Telenor wouldn't be able to install a packaged app from there anyway without some extra steps (involving adb and special certificates).

Comment 11

5 years ago
Created attachment 806050 [details]
This passed validation, on dev, seemingly...the icon size was smaller...as per instrucions on http://www.mozilla.org/en-US/styleguide/products/firefoxos/icons/
(In reply to dejan from comment #11)
> Created attachment 806050 [details]
> This passed validation, on dev, seemingly...the icon size was smaller...as
> per instrucions on
> http://www.mozilla.org/en-US/styleguide/products/firefoxos/icons/

The issue here is that you are supplying a 30x30 icon but in your manifest you say it's 32x32:

    "32": "/Assets/SmallLogo.png"

Please change this to "30" and resubmit - thanks!

Comment 13

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/developers/submit/ on FF26 (Win 7).
Postfix screencast http://screencast.com/t/wfCXeWBfar8a
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.