[crash] B2G process with a SIGSEGV when loading an operator poweron mp4

RESOLVED WONTFIX

Status

Firefox OS
General
--
critical
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: amac, Assigned: sotaro)

Tracking

({crash})

unspecified
ARM
Gonk (Firefox OS)
crash

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [systemsfe][b2g-crash])

(Reporter)

Description

5 years ago
STR:
1. Get carrier_power_on.mp4 from [1] and copy it to the apps/system/resources/power directory on your gaia directory.
2. Make a build from that directory and flash it to the phone.

Expected: 

The phone boots correctly and the initial video is shown. 

Actual: 

B2G process dies with a:

E/VDL_RTOS(  693): ***YAMATO Enabled***
E/OMXNodeInstance(  693): !!! Observer died. Quickly, do something, ... anything...
F/OMXNodeInstance(  693): frameworks/base/media/libstagefright/omx/OMXNodeInstance.cpp:203 !"should not be here, unknown state."
F/libc    (  693): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1)

I can provide a whole logcat if it's needed (although getting one should be as easy as adding the file to a build).

Changing the /system/b2g/webapps/system.gaiamobile.org/application.zip on the phone with one that does not have the offending file makes the phone work correctly.


Note that this particular video file is used on the current (1.0.1) phones where it works correctly (and even should it be incorrect it should most definitely not kill the process).

[1] https://github.com/telefonicaid/firefoxos-gaia-spain/blob/master/power/carrier_power_on.mp4
I think this happened in the past for 1.0.1 while we were working in customisation. I have not found that bug but I am adding Juren just in case he remembers.
Flags: needinfo?(yurenju.mozilla)
What build was this reproduced on? Device?
(Reporter)

Comment 3

5 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> What build was this reproduced on? Device?

Sorry. It's happening on Unagi and it happened to me using Mozilla-Central + master at least since last Thursday night (might have been failing since before, that's just when I made a build with that). I'll post the exact commits of my latest build tomorrow.

Updated

5 years ago
Keywords: crash
Whiteboard: [systemsfe][b2g-crash]
it might be a gecko bug and depend on device, I'm testing it on HD.
Flags: needinfo?(yurenju.mozilla)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865607
I can not access bug 865607. Is there a reason bug 865607 is no disclose to public?
Flags: needinfo?(yurenju.mozilla)
Flags: needinfo?(yurenju.mozilla)
I can not find a reason to duplicate to a secret bug. Reopen this bug.
Assignee: nobody → sotaro.ikeda.g
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
OMXNodeInstance does not handle OMX_StatePause state, then the following crash happened. It is fixed by Bug 871018, but was not applied to Unagi(ics_chocolate). Because, OMXCodec is area of qcom support and qcom already do not support ics_chocolate.

-------------------------------------
F/OMXNodeInstance(  693): frameworks/base/media/libstagefright/omx/OMXNodeInstance.cpp:203 !"should not be here, unknown state."
You can find related patches for hamachi under the following.
https://github.com/mozilla-b2g/gonk-patches/tree/master/all-hamachi/frameworks/base
Set to WONTFIX.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX

Updated

5 years ago
blocking-b2g: --- → -
(Reporter)

Updated

5 years ago
Blocks: 944420
You need to log in before you can comment on or make changes to this bug.