cfx run hangs firefox with simple add-on and selected web page

RESOLVED DUPLICATE of bug 768651

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 768651
5 years ago
5 years ago

People

(Reporter: Karl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to reproduce:

Using firefox 23.0.1 and the last add-on SDK 1.14, build the simple add-on described in https://addons.mozilla.org/en-US/developers/docs/sdk/latest/dev-guide/tutorials/getting-started-with-cfx.html. The main.js file reads:

-----------------------
var widgets = require("sdk/widget");
var tabs = require("sdk/tabs");
 
var widget = widgets.Widget({
  id: "mozilla-link",
  label: "Mozilla website",
  contentURL: "http://www.mozilla.org/favicon.ico",
  onClick: function() {
    tabs.open("http://www.mozilla.org/");
  }
});
 -----------------------

Then from the command line execute "cfx run", twice if required to get an identifier. 

The firefox browser comes up. Then enter this specific skype web page, which for the time being is the only one I have seen that does this. 

http://www.skype.com/en/download-skype/skype-for-windows


Actual results:

Firefox apparently hangs in the middle of downloading stuff for the skype page.


Expected results:

The page should load normally.


Some Additional Details:
1) The hang does not occur if everything is the same (with the add-on installed in firefox). In other words, the add-on works fine with this skype web page as long as firefox is launched normally (not by "cfx run"). Tests with other add-on code establishes that this web site is fine with other add-on code, but not compatible with them being launched by "cfx run". 

2) This web page has other things going on. For example, it brings up a cancel-able panel of some kind that appears essential to the issue. The underlying page does not exhibit this problem if the panel is canceled. The underlying page has a slightly different URI (http://www.skype.com/en/download-skype/skype-for-computer/).

3) This panel that MS displays for this URI can be bigger than the firefox window, but no scroll bars are displayed by firefox to scroll it.

4) Notwithstanding item 3), up and down scrolling of the panel is possible with a mouse wheel.

5) Notwithstanding item  4), an add-on content script using the javascript API window.scrollBy(...) fails to scroll the panel. Given this present bug, the failure to scroll on the API cannot be reproduced using "cfx run". (This failure to scroll on the API was how this present bug was discovered, the debug environment that you get with "cfx run" itself failed on this web page that has these scrolling issues.)
This should be fixed in Firefox 25 as part of bug 768651. I think the easiest workaround until 25 ships (aside from running Firefox 25's beta/aurora builds) would be to disable plugins in the instance of Firefox after you start it up with cfx run.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 768651

Comment 2

5 years ago
It's still hanging for me on youtube.com with Firefox Setup Stub 25.0b7
You need to log in before you can comment on or make changes to this bug.