Closed Bug 916864 Opened 6 years ago Closed 6 years ago

CMD+L when findbar is focused opens the "Open Location" dialog instead of focusing the address bar

Categories

(Toolkit :: Find Toolbar, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED FIXED
mozilla27
Tracking Status
firefox25 --- unaffected
firefox26 + verified
firefox27 --- verified

People

(Reporter: cpeterson, Assigned: evilpie)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. CMD+F to open findbar
2. When the findbar box has input focus, CMD+L to focus the address bar

RESULT:
The "Open Location" dialog is opened instead of focusing the address bar.


This is a regression in Nightly 26. I bisected TBPL builds of mozilla-inbound and identified the pushlog to:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=32b0c06568e9&tochange=295578d99074

So the regression is e10s bug 666816.
Component: General → Find Toolbar
Product: Firefox → Toolkit
Version: unspecified → Trunk
Ok. I assume that this is one of those changes in focus behavior, that I was afraid of. I will have to debug what the actual difference is now.
Attached patch blur-fixSplinter Review
Okay that was a pretty stupid mistake. Basically I was calling the wrong function.

"blur" used to do this: http://hg.mozilla.org/integration/mozilla-inbound/rev/295578d99074#l6.113, which with Finder.jsm is roughly what "removeSelection" does and not focusContent!
Assignee: nobody → evilpies
Status: NEW → ASSIGNED
Attachment #805443 - Flags: review?(mdeboer)
Attachment #805443 - Flags: review?(mdeboer) → review+
Tom, one question: why is it 'roughly' what removeSelection() does? Is the previous blur() implementation doing too much? I see some conditionals in there... are they not valid in the context of Finder.jsm?
Flags: needinfo?(evilpies)
Ah sorry, basically I meant that only the relevant parts of code (actually removing the selection) are in Finder.jsm. Some of the other stuff is not needed anymore, because we don't cache it.
Flags: needinfo?(evilpies)
                         ,,-~*~,,
                       /:.:.:.:.:|
                      |;.;.;.;.;/
                      |.;.;.;.;|
                      ).;.;.;.;|
          ,,-":.:.:.:."~-,;.;|
        (_,,,,---,,_:.:.);.;.;",
      ,-":.:.:.:.:.""-,,/;.;.;.;;,
     (:.__,,,,,,,,,___);.;.;;.;|
     /"":.:.:.:.:.:.:¯""\;.;.;.."
     \",__,,,,,,,,,,,__/;;;;;;/\
      \.::.:.:.:.:.:.:.;.);;;;;/:\
       \,,,,,---~~~~;;;;;;;;,:\
          """~~--,,,,,,,,,,-":::::\
                 \::::::::::::::::::\
https://hg.mozilla.org/mozilla-central/rev/40ec721a38e0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Comment on attachment 805443 [details] [diff] [review]
blur-fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 666816
User impact if declined: pressing ctrl + l opens a very annoying and disrupting dialog
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): none, restores old logic
String or IDL/UUID changes made by this patch: none
Attachment #805443 - Flags: approval-mozilla-aurora?
Attachment #805443 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed with the latest Aurora build.

Environments used:

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build Id:20131010004002 
http://hg.mozilla.org/releases/mozilla-aurora/rev/3f16dc100b1f
Windows 7 Professional SP1 x64 

Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
Build Id:20131010004002 
http://hg.mozilla.org/releases/mozilla-aurora/rev/3f16dc100b1f
Ubuntu 12.04 LTS x64

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/26.0
Build Id:20131010004002 
http://hg.mozilla.org/releases/mozilla-aurora/rev/3f16dc100b1f
OS X 10.8.4
Verified as fixed with the latest Nightly build.

Environments used:

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Build Id: 20131010030202
http://hg.mozilla.org/mozilla-central/rev/aa986b6ce882
Windows 7 Professional SP1 x64

Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0
Build Id: 20131010030202
http://hg.mozilla.org/mozilla-central/rev/aa986b6ce882
Ubuntu 12.04 LTS x64

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0
Build Id: 20131010030202
http://hg.mozilla.org/mozilla-central/rev/aa986b6ce882
OS X 10.8.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.