[B2G][Camera] Sometimes camera freezes after taking series of pictures

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Camera
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: nkot, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 805482 [details]
logcat

Description:
Sometimes camera freezes after taking series of pictures and the user has to restart the app to be able continuing taking pictures.
Possibly Unagi specific issue, does not reproduce on Buri.

Repro Steps:
1) Updated Unagi to Build ID: 20130916040205 
2) Open Camera
3) Take a series of pictures

Actual:
 Camera freezes after taking a few pictures

Expected:
 All pictures are saved, camera viewfinder displays and the user is able to take as many pictures as they want

seeing this error in the logcat:
09-16 11:35:59.903: E/LocSvc_adapter(109): I/<--- int32 loc_event_cb(void*, rpc_loc_client_handle_type, rpc_loc_event_mask_type, const rpc_loc_event_payload_u_type*) line 74 RPC_LOC_EVENT_STATUS_REPORT
09-16 11:35:59.903: E/LocSvc_eng(109): I/<=== status_cb line 724 GPS_STATUS_SESSION_BEGIN

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
See attached logcat

Updated

5 years ago
blocking-b2g: --- → koi?
Keywords: regression, regressionwindow-wanted
I see this on unagi as well--taking pictures doesn't seem to be required, the viewfinder simply freezes eventually. Taking a picture unfreezes the viewfinder, which them seems very laggy. Not sure (yet) if it re-freezes.
(Reporter)

Updated

5 years ago
QA Contact: nkot
Anybody with a non-unagi that see this?
comment 0 implies this is unagi-specific, which makes this a non-blocker.
blocking-b2g: koi? → ---
(In reply to Milan Sreckovic [:milan] from comment #2)
>
> Anybody with a non-unagi that see this?

Just tried with a today-build on hamachi: took 100 photos with no crashes, no signs of performance degradation.
(In reply to Jason Smith [:jsmith] from comment #3)
> comment 0 implies this is unagi-specific, which makes this a non-blocker.

Hardware composer a relevant variable here?  Unagis were canaries in the coal mine for some of the camera/hwc/genlock/gralloc problems, they were only reproducible there for the longest time, so we ignored them.  Then the same ones started showing up everywhere.

Good to see that hamachi works, perhaps that's good news, rather than just the absence of bad.
(Hamachi has its own issues today: see bug 916951.)
Shouldn't be hard to find a problem that was introduced on a Sunday :)
(Reporter)

Updated

5 years ago
Summary: [B2G][Camera]Sometimes camera freezes after taking series of pictures → [B2G][Camera][Unagi] Sometimes camera freezes after taking series of pictures

Updated

5 years ago
Keywords: unagi

Comment 8

5 years ago
if this is just unagi, i agree with comment 3 this is not a priority bug.  please dont spend too much time on this one.
I'm actually going to disregard getting the regression window here as we know this only present on unagi. If someone confirms this shows up on a production device, then feel free to add the keyword again.
Keywords: regressionwindow-wanted
mikeh: Is this still an issue? If not let's close :)
Flags: needinfo?(mhabicher)
Just confirmed that this still happens on unagi, among other problems with a choppy viewfinder.

I tested the most recent 1.4 nightly.
Flags: needinfo?(mhabicher)

Comment 12

4 years ago
Created attachment 8427513 [details]
CameraIssue.jpg

Device    Nexus 4
BuildID   20140516110816
Version   32.0a1
Git Commit info 2014-05-05 16:59:23 d33e4f15

In above build I observed that after taking multiple snaps the capture button stays as shown in the attachment. (Stays Highlighted) and capture does not happen even though the view finder displaying the camera view and trying to focus.
If I put any console.log the issue is not reproducible.
If I enable Setting->Developer-> Debugging via USB -> ADB and DevTools then also the issue does not happen.
Looks like some timing issue.

Other Observation
The only way to come out of this situation is try to lock the screen and unlock.
Hi Mishra, can you reproduce this issue with a more recent build?
Flags: needinfo?(deepak.k.mishra)
Keywords: unagi
Summary: [B2G][Camera][Unagi] Sometimes camera freezes after taking series of pictures → [B2G][Camera] Sometimes camera freezes after taking series of pictures

Comment 14

4 years ago
Hi Mike,
Looks like it can not be reproduced in latest
Device    Nexus 4
BuildID   20140516110816
Version   32.0a1
Git Commit info 2014-05-26 08:37:53 6a391274
Flags: needinfo?(deepak.k.mishra)
Closing per comment 14. If this problem recurs, please open a new bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.