[Wikipedia] When changing the language in settings only changes the article.

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: jaime.dolado, Assigned: adora)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 805496 [details]
2013-09-16-12-09-49.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I had my app in Spanish and I wanted to change the language to English  so I clicked in Setting and select a language.


Actual results:

It only changed the language of the Article. The rest of the app remains in Spanish.


Expected results:

There is already a button below to select the language you want to read the article in so I was expecting in the setting selection language to change the language of the app.
(Reporter)

Comment 1

5 years ago
Created attachment 805498 [details]
Screen Shot 2013-09-16 at 12.10.03 PM.png

Updated

5 years ago
Blocks: 869240
Component: General → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk
(Reporter)

Updated

5 years ago
Priority: -- → P1
(Reporter)

Updated

5 years ago
Severity: normal → major
(Reporter)

Comment 2

5 years ago
Any update of this issue? There is a big problem when changing language in the app.
(Reporter)

Comment 3

5 years ago
Now the bug is getting worse. When I press to see  the article in another language, it changes the article!!
(Reporter)

Comment 4

5 years ago
It is only in the first page. Each language has a first page and when you want to look it up in another language it changes the article.
Priority: P1 → P2

Updated

5 years ago
Assignee: nobody → adora
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

5 years ago
The current way this works is that the UI language should default to whatever your system UI language is, and you change it by changing your system UI language in system settings.

The language selection within the app is for selecting content language, and doesn't change the app UI any more than reading a Spanish or Chinese email changes your email client's UI language to Spanish or Chinese.


However I believe there is some inconsistency between which language you last opened with the "read in language" toolbar button the content language setting, and that's kind of confusing.

I'm not sure what "correct" behavior actually would be, so I'm not sure I can prioritize a fix for this just yet...
(Reporter)

Updated

5 years ago
Severity: major → normal
Priority: P2 → P3

Comment 6

5 years ago
(In reply to Brion Vibber from comment #5)
> The current way this works is that the UI language should default to
> whatever your system UI language is, and you change it by changing your
> system UI language in system settings.
> 
> The language selection within the app is for selecting content language, and
> doesn't change the app UI any more than reading a Spanish or Chinese email
> changes your email client's UI language to Spanish or Chinese.
> 
> 
> However I believe there is some inconsistency between which language you
> last opened with the "read in language" toolbar button the content language
> setting, and that's kind of confusing.
> 
> I'm not sure what "correct" behavior actually would be, so I'm not sure I
> can prioritize a fix for this just yet...

Sounds like this bug is working as intended. We can file another bug in the future if we can reproduce the aforementioned inconsistency between the language last opened with "read in language" function and the content language setting. 

Closing this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.