Hitting "enter" key should dismiss dialogs/alerts

VERIFIED DUPLICATE of bug 59840

Status

()

Core
DOM: Events
VERIFIED DUPLICATE of bug 59840
17 years ago
17 years ago

People

(Reporter: Patrick C. Beard, Assigned: joki (gone))

Tracking

Trunk
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If I bring up an alert using "window.alert('hello')" I should be able to dismiss
it using the enter key, not just the return key. Alerts that come up in mail
news seem to have the same problem. I'm assuing this is just a general event
handling problem.
This to me looks like a dupe of Bug 59840 - "Enter key should bind to default
button on dialog"

Since the bug does not specifically restrict javascript (it mentions that bug
58709 is not a dupe because 58709 is specifically restricted to JS, implying
that 59840 is not).  I would say that it includes this as well.
(Reporter)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 59840 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.