If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dialogs come up with no default focus

VERIFIED DUPLICATE of bug 58853

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 58853
16 years ago
16 years ago

People

(Reporter: Patrick C. Beard, Assigned: saari (gone))

Tracking

Trunk
PowerPC
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Bring up the preferences dialog. Hit the "return" key. Nothing happens. Hit the
"escape" key. Nothing happens. In both cases, the dialog should be dismissed. If
you hit the tab key, nothing comes into focus. Ideally, the selected panel's
item in the list should get focus then, and subsequent tabs should enumerate all
of the focusable items in the panel. For somebody accustomed to bringing up a
dialog, and then canceling it with the escape key (or command-period on the Mac)
this can be very frustrating.
ohhhh saari?
Assignee: aaronl → saari

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 58853 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Preferences navigation meta bug: bug 18575

BTW, I got this info from the brand new 
Access Bug Radar

http://www.mozilla.org/projects/ui/accessibility/access-radar.html

Comment 4

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.