Closed Bug 917054 Opened 6 years ago Closed 6 years ago

[B2G] [Buri] [Keyboard] The special characters for the l key have an extra symbol, l·l

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: ckreinbring, Unassigned)

Details

(Keywords: regression, Whiteboard: burirun1)

Attachments

(1 file)

Description:
The special characters for the l key include the "l·l" symbol.

Repro Steps:
1) Update Buri to Build ID: 20130916040205
2) Add the Spanish keyboard set if it isn't added to the active keyboards.
3) Launch the Messaging app.
4) Tap the Create New message icon then the message textbox.
5) Switch to the Spanish keyboard layout (if it isn't active already) and long-tap the l key.
6) Observe the special characters that appear.

Actual:
The available special characters are £ and "l·l"

Expected:
Only the £ is available as a special character.

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
Test Suite Name: Keyboard
UCID: owd-2684
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=6470
See attached screenshot
No longer blocks: b2g-central-dogfood
blocking-b2g: --- → koi?
QA Contact: nkot
this is a regression from v1.1, all v1.2 builds have "£" and "l·l" special chars for char "l"

not sure if it's important, I've noticed that keyboards in v1.1 are listed in their language (Español, Français, Русский) while in v1.2 they are all listed in English (Spanish, French, Russian)
(In reply to nkot from comment #1)
> this is a regression from v1.1, all v1.2 builds have "£" and "l·l" special
> chars for char "l"
> 
> not sure if it's important, I've noticed that keyboards in v1.1 are listed
> in their language (Español, Français, Русский) while in v1.2 they are all
> listed in English (Spanish, French, Russian)

That's probably a bug as well - can you file a separate bug for that?
sorry for going off-topic here
(In reply to Jason Smith [:jsmith] from comment #2)
> That's probably a bug as well - can you file a separate bug for that?
found the doc for recent keyboard change on master, international keyboards are listed in English there, so not a bug then
https://bug891678.bugzilla.mozilla.org/attachment.cgi?id=776309 (see p.6-7)
According to Bug 845312, it looks like not a bug.
Not a bug, see previous comment.
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.