[B2G][Buri] Internet sharing icon appears in notification bar for few seconds when the search for available WiFi networks is in progress

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mdavydova, Assigned: chucklee)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, firefox25 wontfix, firefox26 verified, firefox27 verified, b2g-v1.2 verified)

Details

(Whiteboard: burirun1)

Attachments

(2 attachments)

Posted file logcat
Description:
Internet sharing icon appears in notification bar for few seconds when device is searching for available WiFi Networks.

Steps to reproduce:
1) Updated Buri to Build ID: 20130916040205
2) Go to Settings 
3) Select WiFi option in Network and Connectivity section
4) Tap on the WiFi toggle to disable it
5) Tap the WiFi toggle again to enable it 
6) Observe the notification bar

Actual:
An internet sharing icon appears for few seconds in the notification bar

Expected:
An internet sharing icon does not show up in the norification bar

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: 50%
Attaching two different logcats for more info
* Same issue happens when user switches an Airplane mode to on and off
blocking-b2g: --- → koi?
Whiteboard: burirun1
QA Contact: mdavydova
Regression range:

Build ID: 20130912040201 - Does not reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/a98569f21abe
Gaia: 9ffd2899eb91388f7fc1ce6f7a895a6f5f922c05
Platform Version: 26.0a1

Build ID: 20130913040201 - Reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/b9029b1de410
Gaia: 8ccb741b6adcfe9a78b842c17e5874242c0f8b86
Platform Version: 26.0a1
Duplicate of this bug: 918757
I think this bug is worse than comment #0 suggests.

The hotspot enabled by default with the generic wifi settings could result in a security breach.

See these STR from bug 918757:

1. Flash device with m-c Inari build
2. Run through FTU without selecting/changing any options
3. Pull down status bar panel and uncheck "Wifi" icon
4. Wait a few seconds, Internet sharing will come on with default insecure settings, hotspot is visible by scanning in the area from another device.
Assignee: nobody → chulee
The disconnect flag should be put alone with the disable command.
Attachment #809723 - Flags: review?(vchang)
Comment on attachment 809723 [details] [diff] [review]
Fix misplaced condition flag.

Review of attachment 809723 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thank you.
Attachment #809723 - Flags: review?(vchang) → review+
https://hg.mozilla.org/mozilla-central/rev/747b3fdceeb2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Component: Gaia::System → Wifi
Seeing as this bug busted the Brussels Summit Wi-fi, reckon we have a case for patching it to 1.2?
Duplicate of this bug: 921613
blocking-b2g: koi? → ---
Duplicate of this bug: 925708
Cleared nom by accident.
blocking-b2g: --- → koi?
Hey Bhavana, could we please get the koi+ flag here, so that it will be uplifted ? It landed more than 2 weeks ago, and it has been asked nearly 1 month ago...

This is a _really_ bad issue.
Flags: needinfo?(bbajaj)
Teams can still plus their own bug fixes. :)  Agreed this is bad, marking blocking.
blocking-b2g: koi? → koi+
Flags: needinfo?(bbajaj)
Duplicate of this bug: 923959
When WiFi is enabled, internet sharing notification is off. When WiFi is disabled, internet sharing notification is on when internet sharing enabled. 

Verified on:

Buri v1.2 Mozilla
Gaia   dbcc171eae6b4d9d168a48291d5ea54c7580561a
SourceStamp 7ca5d1e81d37
BuildID 20131017004001
Version 26.0a2

and 

Buri v1.3 Mozilla
Gaia   616e87af0133496620aea89f21ca5d37acedf466
SourceStamp 423b9c30c73d
BuildID 20131017040202
Version 27.0a1
You need to log in before you can comment on or make changes to this bug.