[B2G][Helix][DataService][zhaotao]device ua string issue

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Assigned: wchang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; aff-kingsoft-ciba; Zune 4.7)

Steps to reproduce:

we have modified the default ua string of our device


Actual results:

Wayne,since you told us that there is some problem with the ua string of our device,and you told us that we should modify the ua string,we want to know the details about exactly what ua string should we use.


Expected results:

Please clarify the ua string issue,what ua string should we use?
(Reporter)

Comment 1

5 years ago
hi,wayne,can you clarify the issue for me?
(Reporter)

Comment 2

5 years ago
hi,wayne,

thank you very much for the clarification.

Now i have another question,mozilla apply ua string override for different website,

Should we delete our device module in the process of ua string override to avoid some website visiting issue?
Wayne - Can you please comment with your clarifications that Lecky refers to in comment 2?

Lecky - The UA overrides are in place to force mobile content for select sites by sending a custom UA to these sites. If you remove an UA override Helix likely won't get mobile content for the site for which the override has been removed.
Assignee: nobody → wchang
Flags: needinfo?(wchang)
(Reporter)

Comment 4

5 years ago
hi,lawrence,

for oem,the ua string should be Mozilla/5.0 (Mobile; XXXX; rv:18.1) Gecko/18.1 Firefox/18.1

XXXX means device module(different for different oem and phone module),

my question is that in the process of ua string override,should device module(XXXX) be deleted?
An UA override is put in place to masquerade Firefox OS as another type of device (typically Firefox for Android or a default Android browser) in order to obtain content from the site that would be served to a different device/browser. As such, by design an UA override hides the device from a site.
(Reporter)

Comment 6

5 years ago
got it,thanks,lawrence!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

5 years ago
Hi Lawrence,

Just for context I shared a copy of "Firefox OS UA Device/Model Inclusion Requirements" (snapshot on 2013/9/17) that you have provided me earlier with Lecky. 

As your document requires a permission to view I am not sure if it's ready to go public yet, I wont paste the entire thing here.
Flags: needinfo?(wchang)
(In reply to Wayne Chang [:wchang] from comment #7)
> Hi Lawrence,
> 
> Just for context I shared a copy of "Firefox OS UA Device/Model Inclusion
> Requirements" (snapshot on 2013/9/17) that you have provided me earlier with
> Lecky. 
> 
> As your document requires a permission to view I am not sure if it's ready
> to go public yet, I wont paste the entire thing here.

For reference, the draft that you referred to has been finalized and publicly published at https://wiki.mozilla.org/B2G/User_Agent/Device_Model_Inclusion_Requirements
(Reporter)

Comment 9

5 years ago
hi,lawrence,

as what you have said:

As such, by design an UA override hides the device from a site.

Should this be done by OEM?

In gecko\netwerk\protocol\http\UserAgentOverrides.jsm,i can not find any code to hide oem device string.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
lecky - There is no change required by this discussion. As such, for continued discussion I suggest that this conversation be moved to one of the mailing lists.

Unfortunately, I'm not clear on what it is that you're asking. Mozilla manages the UA override list at this point. Adding a domain to the UA override list should be a last resort. If you have a specific need to add/remove a domain from the list, I request that you please raise your issue on the compatibility@ or dev-b2g@ mailing lists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.