Redesign: (Docs team work) - Replace in-content multi-article TOCs with quicklinks

RESOLVED DUPLICATE of bug 915627

Status

RESOLVED DUPLICATE of bug 915627
5 years ago
5 years ago

People

(Reporter: sheppy, Assigned: sheppy)

Tracking

Details

(Assignee)

Description

5 years ago
The docs team needs to replace the various in-content TOCs used for multi-page documents (such as the MDN project docs, although that's mostly done already) with quicklinks blocks.

This includes things like the JavaScript Guide, CSS tutorial, etc.

There should be no work here for the dev team, but this should block the beta launch.
Assignee: nobody → eshepherd
Blocks: 914828
No longer blocks: 910513
Component: Design / user experience → General
Product: Mozilla Developer Network → Developer Documentation
What is the impact of not doing this? In favor of doing this during the refinement period (after the beta launch) unless ignoring this this truly makes the site unusable.
Blocks: 914840
No longer blocks: 914828
(Assignee)

Comment 2

5 years ago
This makes certain pages unusable, or at least genuinely awful to use, because the boxes created occupy enough space horizontally in the new design that there's some very ugly wrapping of content.

This is an example (not among the worst, but an example of the kind of mess that can arise): https://developer.mozilla.org/en-US/docs/Project:MDN/Contributing/Custom_macros
Yes, this bug (which is a duplicate of bug 915627 btw, must be fixed before the beta launch.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915627
Blocks: 910513
No longer blocks: 914840
You need to log in before you can comment on or make changes to this bug.