[browser] 'Unbookmark' and 'Edit bookmark' menu items shown in Bookmarks menu on first invocation in browser session for unbookmarked page

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Boot2Gecko 1.1.0.0-prerelease 20130916041201, Unagi

The 'Unbookmark' and 'Edit bookmark' menu items are shown for an unbookmarked page in the Bookmarks menu on the first invocation of that menu in a browser session.

Steps to reproduce.
1. Launch browser.
2. Visit an unbookmarked page, e.g. http://www.mozilla.org
3. Tap bookmark star.

Actual result:
'Unbookmark' and 'Edit bookmark' are shown along with 'Bookmark' and 'Add to home screen'.


Expected result:
'Unbookmark' and 'Edit bookmark' not shown in menu.
It's unfortunately too late in the v1.1 cycle to block on this so I'm moving the nom to koi.
blocking-b2g: leo? → koi?
Although this is not a good bug at all, I don't think it can be blocking koi due to other priority bugs. If we can get to it after the other blockers, all the better - it will be ranked in the prio / backlog list as such.
blocking-b2g: koi? → -
This should be resolved in the latest trunk.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.