Mail loss during compacting folders.

VERIFIED FIXED

Status

MailNews Core
Networking: POP
--
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Roland van Beek, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
After starting MailNews it asks the user if it should compact the mail folders.
When confirmed it compacts the mail folders and retrieves the POP mail at the
same time. When the compact action is finished the new mail is lost.

Comment 1

17 years ago
How do you confirm that the new mail is lost?

Comment 2

17 years ago
Reporter: which build are you using?

note that a similar problem has been fixed after 0.9.2 in bug 85632
(Reporter)

Comment 3

17 years ago
During de compacting of de INBOX you see in the right hand corner that it
contacts the POP server and retrieve a number of e-mails. After the compacting
of the INBOX the unread count of the INBOX is 0 and there are no new e-mails in
the INBOX.
The check is only visual. 

Comment 4

17 years ago
what's the date of the build you're using, Roland? There have been lots of fixes
in this area recently.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

17 years ago
I now use Build ID 2001071704
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2+) Gecko/20010717
(Assignee)

Comment 6

17 years ago
Created attachment 43287 [details] [diff] [review]
proposed fix.
(Assignee)

Comment 7

17 years ago
so the fix is to lock the folder and do one operation at a time. found 
out another problem with compact folders, logged as bug 92008
(Assignee)

Comment 8

17 years ago
cc jatin for alert wording review

Please try to download the messages later. There is some other operation 
currently in progress on this folder. 

Comment 9

17 years ago
My suggested wording:
"This folder is being processed. Please wait until processing is complete to get
messages."

Comment 10

17 years ago
r=bienvenu. Please get a sr from mscott or seth, and make sure you test the
various failure and cancel cases - if we don't handle those correctly, you'll
end up with a folder that's locked and the user won't be able to use it without
shutting down.

Comment 11

17 years ago
See also bug 89942 (it was marked dup of bug 85632, but in reality it is a dup
of this one).

Comment 12

17 years ago
sr=mscott. Looks like we release lock during the on stop running url yes? That
should be safe as I believe we always issue the on stop running url. Even in the
case of an error.
(Assignee)

Comment 13

17 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

17 years ago
*** Bug 94390 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

17 years ago
*** Bug 94390 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Verified for default pop account in a profile and compaction initiated by 
preference does not result in message loss.  When both get message and 
compaction is triggered at the same time we show a dlg" this folder is being 
processed please wait until process is complete to get message", with an ok 
button. When I click OK then we start the compaction process. After compaction 
is completed when you click on get message I did receive the message that was 
sent to my test account.  


builds:
2001-08-15-06 win98, linux
2001-08-17-04 mac 


Status: RESOLVED → VERIFIED
(Assignee)

Comment 17

17 years ago
*** Bug 96074 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

17 years ago
*** Bug 97757 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 99473 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
Darn... Has happened 2 times for me right now, and silly me i did not make a
backup of my inbox
I clicked on "compact all folders" and my inbox folder lost ALL mails!
All other folders were left the same
Using linux 2001091308
Reopening
Status: VERIFIED → REOPENED
OS: Windows 2000 → Linux
Resolution: FIXED → ---
(Assignee)

Comment 21

17 years ago
This bug is about downloading mail and auto-compact going on simultaneously. 
this is not the bug you are thinking. please report a new bug. 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
As per naving comments marking verified. reporter, please log a new bug. 
Status: RESOLVED → VERIFIED

Comment 23

17 years ago
bug 99741 was filed "compacting mail erases inbox!"
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.