AdbController doesn't exists on b2g desktop and introduce exceptions

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ochameau, Assigned: ochameau)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox25 wontfix, firefox26 fixed, firefox27 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [needs-coverage])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
AdbController is only defined on Gonk, whereas it is called from here, also on b2g desktop:
http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/shell.js#1051
1051       DebuggerServer.onConnectionChange = function(what) {
1052         AdbController.updateState();
1053       }
1054     }

We shouldn't have this code on desktop or implement an empty AdbController implementation.
(Assignee)

Updated

4 years ago
Assignee: nobody → poirot.alex
Blocks: 810092
(Assignee)

Comment 1

4 years ago
Created attachment 806020 [details] [diff] [review]
Fix exception on b2g desktop about undefined AdbController object r=fabrice
(Assignee)

Updated

4 years ago
Attachment #806020 - Flags: review?(fabrice)
(Assignee)

Updated

4 years ago
Blocks: 915258
Comment on attachment 806020 [details] [diff] [review]
Fix exception on b2g desktop about undefined AdbController object r=fabrice

Review of attachment 806020 [details] [diff] [review]:
-----------------------------------------------------------------

thanks, not sure why I didn't see that when testing it...
Attachment #806020 - Flags: review?(fabrice) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c61c7d12e09a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Comment on attachment 806020 [details] [diff] [review]
Fix exception on b2g desktop about undefined AdbController object r=fabrice

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 810092
User impact if declined: b2g desktop remote debugging won't work. as b2g desktop is used for the simulator, we won't be able to debug/install apps on 1.2 simulations
Testing completed (on m-c, etc.): baked on m-c, tested with custom 1.2 builds for the simulator.
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch: none
Attachment #806020 - Flags: approval-mozilla-aurora?
Attachment #806020 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/8b98d09d2077
status-b2g-v1.2: --- → fixed
status-firefox25: --- → wontfix
status-firefox26: --- → fixed
status-firefox27: --- → fixed
Whiteboard: [needs-coverage]
You need to log in before you can comment on or make changes to this bug.