[B2G][Bluetooth][File transfer] Picture in preview shows zoomed in when user opens picture received via Bluetooth.

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: ndavidson, Assigned: heroldtom)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: burirun1)

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 806079 [details]
Zoomed-in preview vs actual pic.JPG

Description:
When user taps on notification that Bluetooth transfer is complete, picture preview opens up, but user is only able to see zoomed-in upper left corner of the picture

Repro Steps:
1) Updated Buri to Build ID: 20130916040205
2) Pair 2 devises via Bluetooth
3) Send pic from device A to device B via bluetooth
4) On device B Tap on notification "File received"
5) Observe what is on a screen when picture preview opens up

Actual:
Picture previue only shows about 1/6 of actual pic on a screen.(it zoomed in to upper left corner of the pic)

Expected:
User is able to see whole picture during preview

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
See attached: screenshot, logcat, 
Optional workarounds - user can see picture normally, if he goes to gallery
Optional extra notes: While zoomed-in in preview mode user is unable to zoom out picture using pinch-in gesture or move zoomed area of the pic around the screen.
(Reporter)

Comment 1

5 years ago
Created attachment 806080 [details]
Recived-PIC-Via-Bluetooth.txt

Updated

5 years ago
Whiteboard: burirun1
cc Gallery expert djf and the owner of Bluetooth file transfer Ian Liu.

Updated

5 years ago
blocking-b2g: --- → koi?
Component: Bluetooth → Gaia::Gallery
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: ssuresh
(Reporter)

Comment 3

5 years ago
Regression window:

Works correctly on 
Buri v1.2 MOZ RIL
Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1

September 5-6 builds had no preview just a black screen

Environmental  Variables:
Build ID: 20130905185329
Gecko: http://hg.mozilla.org/mozilla-central/rev/df8f342e9a6b
Gaia: b77dc7d399c14ac2bafe5c89566b292bc6772d32
Platform Version: 26.0a1

In Builds from September 9 till now - user will get picture zoomed-in, in upper left corner during preview. (It is not only happen when user receives pic over Bluetooth but also if user opens picture attachment from email)

Build it started on Environmental  Variables:
Buri v1.2 moz ril
Build ID: 20130909114657
Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Platform Version: 26.0a1
(Reporter)

Updated

5 years ago
Keywords: regressionwindow-wanted
Flags: needinfo?(mozillamarcia.knous)
This looks like another regression with the patch of bug 900425 and bug 907965. The correct way to call displayImage after that patch should be [1]. But in open.js, it uses the old way to call displayImage[2].

needing info from tom.


[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/gallery/js/frames.js#L331-L337
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/gallery/js/open.js#L113-L160
Flags: needinfo?(therold)
(Assignee)

Updated

5 years ago
Assignee: nobody → therold
Flags: needinfo?(therold)
(Assignee)

Comment 5

5 years ago
Created attachment 810263 [details]
Github Pull Request
Attachment #810263 - Flags: review?(dflanagan)

Updated

5 years ago
blocking-b2g: koi? → koi+
(Assignee)

Comment 6

5 years ago
Created attachment 810670 [details]
Github Pull Request
Attachment #810263 - Attachment is obsolete: true
Attachment #810263 - Flags: review?(dflanagan)
Attachment #810670 - Flags: review?(dflanagan)
(Assignee)

Updated

5 years ago
Attachment #810670 - Attachment mime type: text/plain → text/html
(Assignee)

Comment 7

5 years ago
Created attachment 810671 [details]
Github Pull Request
Attachment #810670 - Attachment is obsolete: true
Attachment #810670 - Flags: review?(dflanagan)
Attachment #810671 - Flags: review?(dflanagan)
(Assignee)

Updated

5 years ago
Attachment #810671 - Attachment mime type: text/plain → text/html
Comment on attachment 810671 [details]
Github Pull Request

r+ if you fix the issues noted on github and test it carefully. (Let me know if you are unable to test bluetooth file transfer from your desktop to your phone).

In particular, please test with the EXIF orientation test images to make sure that they are displayed correctly.
Attachment #810671 - Flags: review?(dflanagan) → review+

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.2: --- → affected
Resolution: --- → FIXED
Uplifted e19bcb49cb6463c9284d26f7df1e3e5c4c3cdcac to:
v1.2: 5bf71fa908a34ddb56f49cdd964815e1e52f8bbc
status-b2g-v1.2: affected → fixed
Flags: needinfo?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.