Right pane content not loading

RESOLVED FIXED

Status

Webmaker
Thimble
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Jacob, Assigned: pomax)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Particularly in Firefox, we're having trouble loading the two Thimble projects featured on http://webmaker.org/teach-templates

The right pane in Thimble displays a blank white page.

Worked for Pomax first time in Chrome, but not for Cade or Jacob in Firefox. Also had problems in Chrome for MJSchranz, but worked upon refresh for him.
(Reporter)

Comment 1

4 years ago
Having the same problem with this user's make - https://thimble.webmaker.org/project/15132/remix

even on refresh, nothing loading on the right pane in Firefox 24
(Assignee)

Comment 2

4 years ago
in FF24 on windows I cannot reproduce the problem. This might be a timing issue relating to the previewloader loading into the preview iframe, and the content getting sent over for rendering.
(Reporter)

Comment 3

4 years ago
Adding Matt and Scott who were able to reproduce the issue in IRC
Flags: needinfo?(scott)
Flags: needinfo?(schranz.m)
The two teach-templates load fine, even in a private tab.

The mario page doesn't load on first try, and refresh from here on out works. I used private tabs to simulate a first try.
Flags: needinfo?(scott)
Same results as scott.
Flags: needinfo?(schranz.m)
(Reporter)

Comment 6

4 years ago
Right now, nothing in Thimble is loading for me on the right pane, even after refresh on Firefox 24 OSX 10.6.8

Had this problem with a different mac the other day that was running Firefox
Summary: Inconsistent loading on /teach-templates projects → Right pane content not loading
(Assignee)

Updated

4 years ago
Assignee: nobody → pomax
Status: NEW → ASSIGNED
I see this on startup sometimes.  It should load a preview of the default page, but it's empty.
(Assignee)

Comment 8

4 years ago
I suspect this is a timing issue caused by the initial "set yourself to this content" postMessage from the main page to the preview iframe getting fired off before the preview iframe is done loading. I'll see if I can make the content message wait, if so, that should fix things.
(Assignee)

Comment 9

4 years ago
Created attachment 810871 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/229

I don't know how to reproduce the original problem on localhost though, so testing this is probably going to require looking at the code and going "this is sensible, let's throw it on staging and see what happens".
Attachment #810871 - Flags: review?(david.humphrey)
You could install the Network Link Conditioner in OS X to slow down your network connection to the point where the bug would be present again
(Assignee)

Comment 11

4 years ago
I found https://github.com/mschrag/speedlimit, which doesn't require XCode but does the same thing quite well - confirmed that without the patch at "slow" speeds for the preview loader the problem manifests. With the patch code, the problem is gone.
(Assignee)

Comment 12

4 years ago
How this can be easily tested: in the thimble views/friendlycode.html change the previewloader to "http://localhost:9876/previewloader.html", install "http-server" with "npm install -g http-server" and then in thimble.webmaker.org/public/friendlycode/templates run "http-server -p 9876", then start up thimble in the usual way.

Throttle the speed for traffice over 9876 on localhost, and observe the effect with the iframe.onload in the live-preview.js file commented off, or uncommented. Commented off you should see the original behaviour, with the preview taking a while to load and not getting content set after it finally does. With the code uncommented, it should take a while to load, and when it does should immediately update its content to the thimble-source-indicated content.
(Assignee)

Updated

4 years ago
Attachment #810871 - Flags: review?(david.humphrey) → review?(scott)
Comment on attachment 810871 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/229

Code looks sane.

Curious to see Jcob using it on staging.
Attachment #810871 - Flags: review?(scott) → review+

Comment 14

4 years ago
Commit pushed to master at https://github.com/mozilla/thimble.webmaker.org

https://github.com/mozilla/thimble.webmaker.org/commit/40b2550343b2b1ff2c4f797f9ae26b460c6fd2d6
Merge pull request #229 from Pomax/bug917446

added an iframe onload so that the update postMessage can't get lost.
(Assignee)

Comment 15

4 years ago
landed; marking as resolved. Note: this will not be on production until monday, if you want to verify, please use thimble.mofostaging.net
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.