[B2G][Keyboard] No "globe" icon - unable to select international keyboards

VERIFIED FIXED

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nkot, Assigned: GaryChen)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

(Whiteboard: burirun1)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Description:
The user is unable to select international keyboards after they were added in Settings app, no "globe" icon on the keyboard.

Repro Steps:
1) Updated Buri to Build ID: 20130916040205
2) Open Settings -> Selected keyboards -> Add more keyboards
3) Add a few international keyboards
4) Open Messages app
5) Tap the Create New message icon 
6) Tap the message textbox
7) Observe the keyboard

Actual:
 "globe" icon to select international keyboards is missing

Expected:
 "globe" icon is available, the user is able to switch b/n selected in Settings keyboards

Environmental Variables
Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Notes:
Repro frequency: 100%
(Reporter)

Comment 1

4 years ago
regression range:
Build ID: 20130915040205 - Does NOT reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/9366ee039645
Gaia: 3f51f302c3a0c57d8bad482ec7ee86b2819389fb
Platform Version: 26.0a1

Build ID: 20130916040205 - Reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1
Keywords: regression

Updated

4 years ago
Whiteboard: burirun1

Updated

4 years ago
blocking-b2g: --- → koi?
Assign to Rudy to verify.
Assignee: nobody → rlu
blocking-b2g: koi? → koi+
Flags: needinfo?(rlu)
Created attachment 811936 [details]
device-2013-09-30-173505.png

I can not reproduce on pvt unagi nighlty build.

mozilla-central revision="e56505c62aba"
gecko.git revision="1211ef6f06ca89501dd9edd0bedaa13a6e6161ac
gaia.git revision="1992915b07cd9d959b26ae0fd0f6d7e549879d72
steal it.
I can help the follow up discuss.
Assignee: rlu → gchen
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rlu)
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 5

4 years ago
I will verify it later.
Many thanks!

-------- Need info. myself --------
Flags: needinfo?(whsu)
(Reporter)

Comment 6

4 years ago
(In reply to GaryChen [:GaryChen] from comment #3)
> Created attachment 811936 [details]
> device-2013-09-30-173505.png
> 
> I can not reproduce on pvt unagi nighlty build.

Hi,
looks like it only reproduces with Messages app, "globe" icon appears in the keyboard in Contacts, Browser, Calendar, and Email
(Reporter)

Updated

4 years ago
Keywords: qawanted
Reopen for comment 6
Status: RESOLVED → REOPENED
Flags: needinfo?(whsu)
Resolution: WORKSFORME → ---

Comment 8

4 years ago
After I double check this case, I found the bug only happened on message app as nkot mentioned.
Thanks!
Created attachment 812528 [details]
pr.html

Hi Jan,
   I think the root cause is we use |TYPE_GROUP_MAPPING| to make input type regular.
   When user focus on 'textarea' and then |supportsSwitching| API will get zero keyboard layout, since 'textarea' is mapped into 'text'.
   
   Here is my patch, please help to review it, thanks.
Attachment #812528 - Flags: review?(janjongboom)
Comment on attachment 812528 [details]
pr.html

General idea is good, as I don't want to recreate this list within Gecko. But I don't like that we do another full loop over the keys of TYPE_GROUP_MAPPING in every iteration. Should create a lookup table for that on file init.

Something like:

var lookup = Object.keys(TYPE_GROUP_MAPPING).reduce(function(res, curr) {
  var k = TYPE_GROUP_MAPPING[curr]
  res[k] = res[k] || [];
  res[k].push(curr);
  return res;
}, {})

I'll r+ it if addressed.
Attachment #812528 - Flags: review?(janjongboom)
Comment on attachment 812528 [details]
pr.html

Good point!!
I've addressed your comment on this patch, please help to review it again.
Attachment #812528 - Flags: review?(janjongboom)
Comment on attachment 812528 [details]
pr.html

Thanks for addressing Gary, tested in Fx Nightly and works fine.
Attachment #812528 - Flags: review?(janjongboom) → review+
travis passed:
https://travis-ci.org/mozilla-b2g/gaia/builds/12077626

merged in gaia master
https://github.com/mozilla-b2g/gaia/commit/dad4feeff91141b0783dc4497278cd89e9cba98d
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Uplifted dad4feeff91141b0783dc4497278cd89e9cba98d to:
v1.2: 567b62616432c802e7a4d5adca79483b162315a6
status-b2g-v1.2: --- → fixed

Updated

4 years ago
Duplicate of this bug: 924842

Comment 16

4 years ago
Hi, all,

Great!!! I verified this patch. I cannot reproduce this bug.

* Test Build:
 - Gaia:     e378651483294c0e26c912b73ac6f6c906e553d3
 - Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/c8e97fd5b94d
 - BuildID   20131011004001
 - Version   26.0a2

Attaching the screenshot.
Status: RESOLVED → VERIFIED

Comment 17

4 years ago
Created attachment 815822 [details]
Message app - Launching the keyboard

Comment 18

4 years ago
As per comment 16, Changing the status-b2g-v1.2 Tracking flags to Verified.
status-b2g-v1.2: fixed → verified
For people watching: Please note that this doesn't work in Fx Nightly at the moment due to bug 927302.
It works on the device & B2G desktop of course, but you know.
You need to log in before you can comment on or make changes to this bug.