Changes to dock badge string don't get reflected

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 806224 [details] [diff] [review]
badgestring.patch

I was playing around with the hook to alter the dock icon badge string using an observer on the topic "before-unread-count-display", which was introduced with bug 274688. Supplying an empty string successfully suppresses the displaying of the count. However, any non-empty string is not displayed. Instead, the actual (original) count is displayed.
(Reporter)

Comment 1

5 years ago
The problem is that always "total.get()" is displayed, unless the displaying was aborted due to an empty string from an observer. The attached patch should fix this, instead of displaying "total.get()", "badgeString" is always displayed (which is initialized with "total.get()").

Comment 2

4 years ago
Fixed on changeset 15743:64b07ee8a793? http://hg.mozilla.org/comm-central/rev/64b07ee8a793, bug 918783

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.