In Search Messages, `Search' should look like the default button

VERIFIED FIXED in mozilla0.9.5

Status

--
minor
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: mpt, Assigned: bhart)

Tracking

Trunk
mozilla0.9.5
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2001072008, Mac OS 9.1

To reproduce:
1.  In mail/news, open the Search Messages window.
2.  Look at the `Search' button.

What you should see:
*   A button with a border around it indicating that it is the default button
    (i.e. that it reacts to the Enter key).

What you actually see:
*   A button which looks like any other.

Comment 1

17 years ago
Reassign
Assignee: naving → hwaara
OS: Mac System 9.x → All
Hardware: Macintosh → All

Updated

17 years ago
Depends on: 91753

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla1.0
(Assignee)

Comment 2

17 years ago
Created attachment 49547 [details] [diff] [review]
patch to make "search" the default button
(Assignee)

Comment 3

17 years ago
Reassign to me
Assignee: hwaara → bhart00
Can't see why this wouldn't be desired, but since in other dialog our buttons
are defaulted, is this fine, Jennifer? The spec currently doesn't have it
highlighted by default.  Here's a screenshot of the patch in my tree.  If
Jennifer approves, r=stephend@netscape.com.  Thanks, Bradley.

Comment 6

17 years ago
Please keep me on the CC list when reassigning.  Thanks.

Comment 7

17 years ago
Comment on attachment 49547 [details] [diff] [review]
patch to make "search" the default button

r=hwaara
Attachment #49547 - Flags: review+

Comment 8

17 years ago
Sounds good.
Comment on attachment 49547 [details] [diff] [review]
patch to make "search" the default button

sr=sspitzer
Attachment #49547 - Flags: superreview+
Fixed on trunk.  If anyone wants this for branch, re-open, and put nsbranch in
the keyword field.
Meant to mark it fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
minor polish issue to give the search button the highlight when it is the
default button in the dialog. 
Status: RESOLVED → REOPENED
Keywords: nsbranch+
Resolution: FIXED → ---
Target Milestone: mozilla1.0 → mozilla0.9.5

Updated

17 years ago
Blocks: 99508

Comment 13

17 years ago
Looks like a small safe patch, with some user upside. Pls bring it to PDT
tomorrow @ noon for review.

Updated

17 years ago
No longer depends on: 91753

Comment 14

17 years ago
PDT+. Pls check it into today.
Whiteboard: PDT+

Comment 15

17 years ago
I just checked this into the branch. 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
OK in the sep19 0.9.4 commercial branch build: win98, linux rh6.2, mac OS 9.1,
OS X.  Modern skin shows search button as default like the attached screenshot.
Classic skin shows search button as other dialogs' default buttons.
Verified in branch. Will check the trunk.
Keywords: vtrunk

Comment 17

17 years ago
OK with sep19 commercial trunk build.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: vtrunk
(Assignee)

Updated

17 years ago
Blocks: 88476
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.