Closed Bug 917523 Opened 8 years ago Closed 8 years ago

Repair and turn on xfailed test_settings_change_keyboard_language.py

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jlal, Assigned: zcampbell)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Blocks: 917525
TBPL or device?
A locator has changed and needs to be updated then this test can be re-enabled.
Summary: turn on xfailed test_settings_change_keyboard_language.py → Repair and turn on xfailed test_settings_change_keyboard_language.py
Assignee: nobody → zcampbell
Duplicate of this bug: 920450
Attached file pull request (obsolete) —
Attachment #809811 - Flags: review?(florin.strugariu)
Comment on attachment 809811 [details] [review]
pull request

The changes look good, and the test in passing on latest master build
Attachment #809811 - Flags: review+
This was merged in:
https://github.com/mozilla-b2g/gaia/commit/3ca1ab7595d79f5a3b8351ed1c2a4fdaa664404b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attachment #809811 - Flags: review?(florin.strugariu) → review+
Unfortunately, this test is failing in the TBPL Gaia UI test suite. Backed out.
https://github.com/mozilla-b2g/gaia/commit/972233acd826d661b27f9cf92de167e73cb8b752

https://tbpl.mozilla.org/php/getParsedLog.php?id=28346859&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can someone re-land this but with "skip-if not desktop" in the manifest file?

This test works fine on device and with the above backout we have lost coverage so we will just skip it for Travis/TBPL.
I mean "skip-if desktop" :D
Attachment #810143 - Flags: review?(zcampbell)
Note that this test fails because of gaia bug 920853. The attached pull request will cause it to be xfailed on device and not run at all on desktop, but we likely want it running on desktop once the bug has been fixed.
A correction to my comment above. The test will not run on TBPL, but will only be excluded from desktop as it is xfailed. It is not explicitly marked to not run on desktop.
Attachment #809811 - Attachment is obsolete: true
Merged https://github.com/mozilla-b2g/gaia/commit/73907d67deca04f9a272f0cbfde26bb810d2e219
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Attachment #810143 - Flags: review?(zcampbell) → review+
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.