Reduce blocklisting of depth_texture to Mac+NV <=10.8.2

NEW
Unassigned

Status

()

Core
Canvas: WebGL
4 years ago
2 years ago

People

(Reporter: jgilbert, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [games])

(Reporter)

Description

4 years ago
In bug 814839, we hit a crash at least Mac 10.8.2 machines with at least one NV card in the WebGL conformance tests for depth_texture. To resolve it, we blocked packed_depth_stencil on NV+Mac.

In bug 908905, we switched to blocklisting depth_texture instead of packed_depth_stencil on these systems.

We should further reduce this so it's only blocked on <=10.8.2, and not >=10.8.3.

Comment 1

4 years ago
Is there a way to force-enable this on a OSX system?

Updated

4 years ago
Whiteboard: [games]
(Reporter)

Comment 2

4 years ago
You could disable the driver workaround pref, but that might break other things. It's pretty all-or-nothing.

We don't have a pref for ignoring this specific protection.

Updated

4 years ago
Blocks: 710398
You need to log in before you can comment on or make changes to this bug.