mozilla doesn't always use the proxy server [junkbuster]

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: jmd, Assigned: bbaetz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux 2001072008.

Mozilla is configured to use an HTTP proxy of localhost port 8000. Watching
network dumps and the proxy logs reveal it doesn't always use it. For example,
going to www.theregister.co.uk, it only gets twelve of the files through the
proxy, the rest it requests direct.

Netscape 4.7 requests all of the files through the proxy (approx. seventy).
(Assignee)

Comment 1

18 years ago
Hmm. What proxy server are you using? (It shouldn't make a difference, but it
might be)
(Reporter)

Comment 2

18 years ago
Junkbuster 2.0.2, sorry, I /was/ going to mention that ;).

Still, no matter how buggy the proxy, Mozilla shouldn't just skip it for a few
files here and there.
(Assignee)

Comment 3

18 years ago
Does this still happen if you set the protocol version to 1.0 (in the debug pref
panel?)
(Reporter)

Comment 4

18 years ago
Looks like that clears it up.

There still is a Mozilla bug here, though... it shouldn't be only partly using
the proxy server, no matter what kind of problems it has, should it?

In that last testing (with 1.1), it got a total of 2 (of the 70) files through
the proxy.
(Assignee)

Comment 5

18 years ago
junkbuster is not 1.1 compliant, and you're going to run into lots and lots of
bugs with it. However, we shouldn't be bypassing the proxy though. I'll look
into this...

Updating summary
Assignee: neeti → bbaetz
Summary: Mozilla not always using proxy → mozilla doesn't always use the proxy server [junkbuster]

Comment 6

18 years ago
FWIW, I never see this happen with my squid proxy.

Might java or some plugin be ignoring the proxy?

Comment 7

18 years ago
Mozilla also ignores an http proxy with protocol 1.1 under Linux using
junkbuster 2.0.  I get burned with it at www.m-w.com (merriam-webster's
dictionary site) on the ad at the top of the page.
(Assignee)

Comment 8

18 years ago
OK, this is invalid. I presume that you're testing this by looking at the
junkbuster logs? junkbuster is not spec compliant in many ways, and if there is
a keep-alive request, it only logs the first connection, since all it cares
about is the first one - after that it keeps the connection open until it closes.

If this isn't the case, please reopen, but I can't reproduce this.

IMPORTANT NOTE: on current trunk builds (anything from after friday afternoon)
we're now going to be reusing connections to proxy servers for different hosts.
(since we're talking to the same proxy server, and persistancy is hop by hop).
See bug 84264. Since junkbuster is totally and utterly broken, this probably
means that it will no longer work at all unless you turn keep-alives off. You
probably need http/1.0 as well. This will make browsing slower, especially if
you're over a modem.

tor: does this occur for you, with your patch? It probably will, I think.

I'll update the junkbuster relnote after hearing back.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 9

18 years ago
I was wondering if you could make heads or tails of the trace when the Proxy is
running on localhost. All of your network connections would leave from your
system to the origin server right? Unless you did something like configure
Junkbuster to use a different outbound interface than direct connections.
(Reporter)

Comment 10

18 years ago
benc: I think what I was seeing was caused by trying to use keep-alive 
connections through junkbuster, as bbaetz said. I presume NS47 doesn't use
keep-alive through proxies, so that's why all hits were loged for it for it.

Comment 11

16 years ago
Verified invalid. Dupe of bug 38488
Status: RESOLVED → VERIFIED
QA Contact: benc → junruh
You need to log in before you can comment on or make changes to this bug.