Subject: =?ISO-8859-1?Q??= should display empty subject

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: thomas.hebinck, Unassigned)

Tracking

24 Branch
x86
Windows Server 2003

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

136 bytes, application/octet-stream
Details
(Reporter)

Description

4 years ago
Created attachment 806529 [details]
mail.eml

User Agent: Mozilla/5.0 (Windows NT 5.2; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130909203154

Steps to reproduce:

I have mails like this:

Date: Wed, 01 Jan 2020 00:00:00 +0100
Subject: =?ISO-8859-1?Q??=
MIME-Version: 1.0
Content-Type: TEXT/plain; CHARSET=iso-8859-1



Actual results:

With TB17, an empty subject was displayed.
After upgrading to TB 24.0, the encoding is shown.


Expected results:

The subject should be empty.
http://www.ietf.org/rfc/rfc2047.txt
>   encoded-word = "=?" charset "?" encoding "?" encoded-text "?="
>   encoded-text = 1*<Any printable ASCII character other than "?"
>                     or SPACE>

"=?ISO-8859-1?Q??=" is invalid as an encoded word because at least one character is needed. Thunderbird 17 incorrectly decoded the "encoded word", then Thunderbird 24 fixed the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.