Control + A for selecting everything is not working

RESOLVED FIXED in Firefox 28

Status

P2
major
RESOLVED FIXED
5 years ago
2 months ago

People

(Reporter: leo, Assigned: paul)

Tracking

unspecified
Firefox 28
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=js][mentor=msucan][good first verify])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
You cannot select the entire content of the console input field by pressing the normal shortcus Control + A. It simply is doing nothing. But thats a problem, because sometimes you just want to clear the entire input field.
Thank you for the bug report. Ctrl-A/E are working as expected on Linux. We had this discussion previously in bug 623749.

(leaving open until the next web console bugs triage when we will decide if we want to change this behavior or not)
(Reporter)

Comment 2

5 years ago
In my opinion this is a bug. Because for jumping to the first/last position of the input field you already habe the "pos1" and "end" key on your keyboard. Also the field down there is not a reall command line, so the comparison to the linux terminal is not correct.

In every input element CTRL+A ist select all. Why try to change it in this case?
The team discussed this and consensus was to keep the existing behavior. FWIW you can use Ctrl-Shift-A to Select All on Linux.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 4

5 years ago
I'm going to be the annoying guy here :)

Re-opening because this behavior always seriously bugged me.

(In reply to Leo Unglaub from comment #2)
> In every input element CTRL+A ist select all. Why try to change it in this
> case?

I agree. Even in other browsers Ctrl-A selects the line.

(In reply to Panos Astithas [:past] from comment #3)
> The team discussed this and consensus was to keep the existing behavior.

Can we re-discuss that?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Priority: -- → P2
let's do this for windows only because those users have a HOME key to get to the beginning of the line.
Whiteboard: [good first bug][lang=js][mentor=msucan]
(Assignee)

Comment 6

5 years ago
I want that for Linux :(
Well, everyone can press some version of a Home key...  Windows and Linux machines tend to have an explicitly labelled key.  For Mac, Apple's extended keyboard has a Home key, or you can press Fn + Left Arrow to get the same thing.
(Assignee)

Comment 8

5 years ago
Created attachment 8336707 [details] [diff] [review]
ctrl-a
(Assignee)

Comment 9

5 years ago
Created attachment 8336709 [details] [diff] [review]
v1

https://tbpl.mozilla.org/?tree=Try&rev=4ef1b1a9bcea
Assignee: nobody → paul
Attachment #8336707 - Attachment is obsolete: true
Status: REOPENED → ASSIGNED
Attachment #8336709 - Flags: review?(mihai.sucan)
Comment on attachment 8336709 [details] [diff] [review]
v1

Review of attachment 8336709 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!

::: browser/devtools/webconsole/webconsole.js
@@ +3984,5 @@
>            // control-a
>            this.clearCompletion();
>  
> +          if (Services.appinfo.OS != "Darwin") {
> +            // Allow Select All on Windows and Linux.

This is fine, but do we need to keep the code for this case (ctrl-a)? Afaik, ctrl-a is implemented natively on macs. Can you please check?
Attachment #8336709 - Flags: review?(mihai.sucan) → review+
(Assignee)

Comment 11

5 years ago
(In reply to Mihai Sucan [:msucan] from comment #10)
> This is fine, but do we need to keep the code for this case (ctrl-a)? Afaik,
> ctrl-a is implemented natively on macs. Can you please check?

You're right.
(Assignee)

Comment 12

5 years ago
Created attachment 8336735 [details] [diff] [review]
v2
Attachment #8336709 - Attachment is obsolete: true
Attachment #8336735 - Flags: review?(mihai.sucan)
Comment on attachment 8336735 [details] [diff] [review]
v2

Thanks!
Attachment #8336735 - Flags: review?(mihai.sucan) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/437b05dda7ca
Keywords: checkin-needed
Whiteboard: [good first bug][lang=js][mentor=msucan] → [good first bug][lang=js][mentor=msucan][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/437b05dda7ca
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug][lang=js][mentor=msucan][fixed-in-fx-team] → [good first bug][lang=js][mentor=msucan]
Target Milestone: --- → Firefox 28

Updated

5 years ago
Whiteboard: [good first bug][lang=js][mentor=msucan] → [good first bug][lang=js][mentor=msucan][good first verify]

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.