URL displays source code instead of rendering [http/0.9]

VERIFIED DUPLICATE of bug 75177

Status

()

VERIFIED DUPLICATE of bug 75177
17 years ago
17 years ago

People

(Reporter: chris.stone, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010721
BuildID:    2001072106

When viewing this URL an ad is supposed to show up, but instead the source code
for the page is displayed.  When you attempt the view the source code using
View->Page Source, the save file dialog box opens with what appears to be a
random filename.  The ad displays properly with Opera.

Reproducible: Always
Steps to Reproduce:
1.  Browse to the URL specified


Actual Results:  Source html is displayed instead of a gif image of an ad

Expected Results:  gif image of an ad is supposed to be displayed

Unexpected results occur if you attempt to view the page source after the page
is "rendered".
confirming, moving to networking: http.

This server gives http/0.9 responses, but its response varies based on the
user-agent header. Really odd....
Assignee: asa → neeti
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: HTTP
Ever confirmed: true
QA Contact: doronr → benc
Summary: URL displays source code instead of rendering → URL displays source code instead of rendering [http/0.9]
Duplicate of "http 0.9 rendered as content-type: text/plain"

fix is being reviewed at the moment.

That servers returns utterly crapy HTML, by the way.  Read the bug this is a dup
of...

*** This bug has been marked as a duplicate of 75177 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.