Closed Bug 917791 Opened 6 years ago Closed 6 years ago

Increase pan / fling refresh rates for metrofx

Categories

(Firefox for Metro Graveyard :: Pan and Zoom, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file, 1 obsolete file)

We have a couple constants here - gPanRepaintInterval (250 msec) and gFlingRepaintInterval (75 msec). Both seem rather high for metro (and in general). Changing these to more reasonable values (20 fps / 50 msec) really seems to smooth out our scrolling. Kats, any thoughts on this?
I think doing that makes sense for Metro because you're running on higher-powered devices than FFOS which is what these values were tuned for originally. Note that the values are preffed so it should be a simple matter to just adjust the prefs in the metro default prefs file.
Attached patch fix (obsolete) — Splinter Review
Attached patch patchSplinter Review
prefs change for 20 fps scrolling
Assignee: nobody → jmathies
Attachment #807340 - Attachment is obsolete: true
Attachment #809121 - Flags: review?(bugmail.mozilla)
Comment on attachment 809121 [details] [diff] [review]
patch

Review of attachment 809121 [details] [diff] [review]:
-----------------------------------------------------------------

Fine by me :)
Attachment #809121 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/7ec69b142816
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
This change didn't actually take effect because of bug 936027.  Now that bug 936027 is fixed, we are actually using the new prefs, and it seems like a regression to me.  We are now painting several times more often (especially during flings) which seems to increase jank on my Surface Pro.  Should we revert to the original default values?
Depends on: 936027
Yeah I was seeing this too. We probably want to increase the interval at least, even if we don't revert back to the original defaults.
I'm not seeing any jank on an sp1, and the black rects problem has diminished as well. I can try adjusting the values and see what happens.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.