nic.ar - the form submission does not go to the page indicated by the action property of the form element.

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Spanish
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Guillermo Torreiro, Assigned: Nicolás Lichtmaier)

Tracking

Details

(Whiteboard: [XBROWSER-HTML], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628
BuildID:    20010628

In the page at http://www.nic.ar/requerimientos/estado.htm there is a form with
two buttons; the one named "Ver Trámites" when clicked should go to the
following page: "http:/cgi-bin/nic/constram.cgi", that is the action's value
property in the form, but instead it's not going there and trigger the search
funcionality of Mozilla.

Reproducible: Always
Steps to Reproduce:
1.go to "http://www.nic.ar/requerimientos/estado.htm"
2.in the last text box named "Ingrese el Nombre del Dominio" enter a domain name
(for example: linux.com.ar)
3.and then click "Ver Trámites"

Actual Results:  Instead of going to the result page on
http:/cgi-bin/nic/constram.cgi, it does one of two thing: 1) show "bad gateway"
message or 2) trigger Mozilla's search facility (like when you click search on
"My Sidebar".

Expected Results:  It should go to http:/cgi-bin/nic/constram.cgi and show the
result of the requesting action, that is to know where a domain name is on his
registration process or not and that information is shown using a HTML Table
with at least two rows. (a very simple page)

the URL "http:/cgi-bin/nic/constram.cgi" that is place in the action's value
property of the form on "http://www.nic.ar/requerimientos/estado.htm" is in
other browser modified into the following:
"http:/www.nic.ar/cgi-bin/nic/constram.cgi" when the page was submitted and it
is showing the results.
That is not the case on Mozilla.
Over to evangelism.  http:/cgi-bin/nic/constram.cgi is not a valid URL per RFC 2396.

See bug 32966 for details.
Assignee: rods → bclary
Status: UNCONFIRMED → NEW
Component: Form Submission → Evangelism
Ever confirmed: true
QA Contact: vladimire → zach
Whiteboard: [XBROWSER-HTML]

Comment 2

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 3

17 years ago
-> Euro
Assignee: bclary → nitot
Component: US English → European
QA Contact: zach → momoi

Comment 4

17 years ago
->Americas.
Assignee: nitot → momoi
Component: European → The Americas
QA Contact: momoi → jonrubin
Summary: the form submission does not go to the page indicated by the action property of the form element. → nic.ar - the form submission does not go to the page indicated by the action property of the form element.
(Assignee)

Comment 5

17 years ago
I've just emailed nic-argentina@mrecic.gov.ar about this problem.

Comment 6

16 years ago
Nicolás, 

Thanks for your offer to help with Argentine bugs. These are now assigned
to you.
Assignee: momoi → nick
file gone. problem gone.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
tech evang june 2003 reorg
Component: The Americas → Spanish
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.